TAZ 6, z axis scaling

So, my stock TAZ is consistently making things a bit bigger in the z dimensions then they should.

The zscaling factor is not constant either. For a print that’s supposed to be 1.5mm thick I got 1.63mm and for a “calibration cube” 30x30x30 I got 30.03x30.03x30.33…
These are printed with .1mm layers after a .2mm initial layer.

This obviously prevents me from expecting any kind of consistency…

Is this a Cura issue? I am setting a 1.5mm thick top and bottom but I would assume Cura would not trip over this and know how to handle things thinner than 3mm, right? I’ve encountered this issue with other Cura driven printers (ender 3) but did not expect this with the Taz 6.

The same issue seems to be present with my Lulzbot Mini 1.

Printing PLA+ (duramic) at 230C, if it makes a difference.

In the various settings menus, find the X and Y steps/mm setting – you will likely find that they are set to 100.50 – I adjusted mine to 100.0 exactly, and it made it a lot better.

Note that for small calibration cubes, horizontal expansion of the filament becomes a more significant factor (over-extrusion + filament properties). So I allocated some spare filament and a lot of time to print very large calibration parts – stretch the cube in the X axis to fit most of the bed, and shrink it in the z-axis to save time and filament. Over a couple hundred mm, the error caused by overextrusion is minimal.

And don’t forget to let the printed part come to room temperature before measuring – parts will shrink as they cool, ABS is particularly bad but all plastics do this to some degree.

thanks for the reply.
as you can notice, all parts are larger than they should be.

i will look in the menus for the x/y/z steps/mm setting… but aren’t those absolute and not “percent”. also this does not explain why the zscaling of off by different percents for thin and thick parts.

for my 1.5mm piece, the result is 1.63mm thick. that would be 8.6% too big. For the calibration “cube”, the resulting z scale error is 1.1% too big. The x and y expansion is really minimal, 0.1%.

also i have the experience of other printers (flashforge guider 2s) being spot on with all dimensions, using the same exact filament, but they are using a different slicer.

my feeling is this is slicer related, not printer related.

I got my steps/mm with M502 and they are 100.5, 100.5, 1600

I also printed a more complex calibration z tower and I get 5.29mm instead of 50.27 instead of 50, 75.30 instead of 75.30 and so on. They’re all .3mm too tall.

So it’s seem I have a pretty much .3mm built in offset after 5mm thickness. Except my large and flat functional 1.5mm thick piece that prints to 1.63mm (plastic melting and flowing?, should I try a cold bed instead? I print with a 60C bed).

Also, still have that offset. What gives?

can no one help ? lulzbot peeps :)?

Have you calibrated your extruder steps (e steps)? Thats about all I can think of with the details provided.

Yes I have.

But how would this explain that .3mm offset?

Also, in case they’re not quite right, cause I don’t know how I would measure and mark of 120mm filament better than I already did (calipers, very thin marker), in what direction should I vary them to compensate for what I see?

alright, another thought. would an incorrect z offset cause this? how do i find the “correct” z offset?

the esteps is pretty intuitive, if you need more material coming out bump up the number, if you need less the lower it. You could try playing with the z-offset in small increments to see if it affecting your print in the way you are expecting.

yeah i wish there was a better way of doing this. i tried loading the test gcode for taz 6 to tune my z offset and it places is in the corner of the bed instead of the center.

it’s now set to -1.1 mm