Taz 6 Aerostruder Z Axis Won't Home

I upgraded my stock taz toolhead to the aerostruder toolhead and updated the firmware for it. Now my Z Axis doesn’t home. The z axis just goes up instead of down when above the z min switch. Has anybody else had this issue? I’ve tried all the latest firmware from 1.1.5 to 1.1.9.

Are you able to control the Z-axis properly when giving commands through Cura or the LCD screen? Can you please try opening a console window and issue M119 then send command, with all of the axis centered and away from the endstops. You can issue a console command by selecting monitor from the top left of Cura and then on the right side of the screen you want to look for manual controls. In that area you should see a button that says console, when you select it, it will open a white window with a text entry box along the bottom. The text entry box is where you will want to issue the command. Please let us know what it shows.

I can control the z axis through cura and the LCD. M119 shows endstops and probe open. I switched back to the stock toolhead and tries the latest firmware and it does the same thing. Z axis wont home. The only firmware that works is

Can you please try moving the x and y axis in their full range of motion, while issuing the M119 command each time the axis is all the way in one direction or the other? This will check the endstops to make sure they are working properly. You should only see triggered when the endstop is fully engaged.

The endstops are working like they’re suppose to. I noticed that the probe would show triggered sometimes even though it wasnt touching the washers. If I entered M119 like 3 times within ten seconds the probe would be triggered at least once. I flashed back to firmware and it would show the probe triggered sometimes too but the z axis would home fine.

Sounds like you have a broken/cracked/loose wire on the Z sense lines. Which is triggering? Then trace that set of wires.

Did you make sure when you upgraded the firmware you chose Taz 6 + aerostruder and not Taz 6 + standard?

I originally didn’t upgrade the firmware and my nozzle tried to home in the air because the old toolhead is longer than the aero. Updating to the aero firmware fixed my issue.

Just a guess.