Taz 6, Modular Bed, Aerostruder, compressed prints issue

I am trying to isolate a systemic problem on my 2 taz6 printers both running Archim 2.0, Aerostruder heads, and the latest version of your Drunken Octopus firmware

Problem: Upgraded both a modular bed from Lulzbot. After having made the required Z offset adjustment…

Orig Offset (-1.20) + Lulz Taz correction (+1.50) = new Z offset (+0.3)

i end up with what appears to be compressed prints. Z axis calibration cube 20mm now is at 18.3 mm.

When I swap each back to their respective old bed and reset the Z Offset to -1.20, dimensions return to normal, 20mm Z.

Is there something I am missing that needs to be changed in the firmware to accomodate the height difference.
The only other common thing between them is Prusa slicer which generates the gcode which I upload to separate RPI Octoprint controllers

Has this been reported before? I searched the forums but I might not have asked the right question. Any Ideas?

Your thoughts are most appreciate

Did you update your firmware too? What firmware are you running? I believe when this was reported before, it was that the firmware they used wasn’t set with an appropriate fade height for the bed leveling.

Latest Version of Marcos Drunken Octopus on both

Try it with official firmware and see if the problem persists, or you may have better luck on the DO forums than here. Most people here are running official firmware or custom builds.

It was my understanding that the official firmware does not support the TAZ 6 and ARCHIM 2 combination. Am I mistaken? Original RAMBO was 8 or 16 bit and ARCHIM is 32.


Sorry, no, it does not. I missed that in the list of mods in the first post.

Try previous releases of DO firmware, and if they work, you can notify them that there’s been a regression in functionality. From what I understand, they’re pretty good at fixing it in the next release.

Copy about regression testing with older versions of D.O.

Good call and Thank you

I did not think about that and will look through the change logs to ID hopefully when Fade was implemented.


Fade has been implemented for a very long time, but from what I understand is that they just run a script for all the changes when a new version of Marlin comes out, they’re not re-inventing the wheel every time. If there’s a change in the configuration files that breaks things, they won’t know unless it’s reported, since they certainly don’t have every combination to test on.

I submitted an issue about this to Lulzbot, my findings isolated it to the M420 Zxx fade in the mesh leveling. Turn that off to see if that fixes it.

You both totally NAILED IT.

Thank you so much.

Setting the fade to zero under motion in Marlin 2.1 eliminated the squish. It was driving me nuts.

I do not understand why the value of 10 worked with the original bed and the +1.5mm shift resulted in the ~8mm value of squish. I might play around with values of 5,4,3, 2, and 1 to see if there is any noticeable value to the option at all.

Again thank you