Taz Pro - Print head 2 doesn't lower for wipe or bed leveling

Just got my new Taz Pro and can’t get to the test print. When the print cycle starts, head 1 goes through the wipe, then it moves over to wipe head 2, but head 2 doesn’t lower, so it wipes nothing. Then it goes on to the bed level procedure and again, head 2 does not lower, so it ends up failing. Any ideas?

Make sure your extruder 2 actuator wire harness is properly connected.

This is described in section 19 of this page: https://ohai.lulzbot.com/project/final-assembly/quiver/

You’ll need to remove the cosmetic cover (with the LulzBot logo) which is attached with 3 screws and this will let you access the wire harnesses. They plug into a board on the x-axis carriage. These are small wire harnesses (I think it’s just 3 wires… white, red, & black). They control the lifting & lowering of the extruder.

I forgot to mention… bed level is only performed with 1 extruder nozzle. Extruder 2 is not normally used for bed leveling (you could force it to use nozzle 2 by modifying the g-code but the factory default g-code uses nozzle 1.) But nozzle 2 should have lowered to clean the nozzle using the wiper pad on the right-side of the build plate.

I’d like to confirm that:

  1. You are using Cura LulzBot Edition 3.6.20 or 3.6.21 (no other software, correct?)
  2. In the Cura preferences panel, pick “Printers” and make sure the printer is “LulzBot TAZ Pro Dual Extruder”.
  3. Click the “Machine Settings” (in the “Preferences” -> “Printers”, select your printer on the list, then click “Machine Settings”
  4. Please verify that in that panel you see “Number of Extruders” is set to “2”.

This will help confirm that you didn’t inadvertently select a different (single extruder) model printer.

Also… in Cura, you get to select the material types used in nozzle 1 independent of nozzle 2.

  1. In the Cura “Prepare” panel, select “Extruder 1” and make sure you selected the material type as “PolyLite PLA (PolyMaker)” (the sample green & black filament is PolyMaker PolyLite PLA).
  2. Select “Extruder 2” and also make sure you selected “PolyLite PLA (PolyMaker)”

When not using an extruder (e.g. for a part that only needs 1 filament) you can set the extruder you are not using to the material named “No Material”. Note that it still does a few things with Extruder 2 even if you aren’t using it.

For example:

  • It still warms the nozzle to the ‘soften’ temp (e.g. 180°) and backs out a bit of filament – I think 10mm worth.
  • It still “wipes” the inactive nozzle on the wiper-pad.
  • It will switch back to the nozzle 1 and perform the bed leveling.
  • It will drop the temp of nozzle 2 down to 100° (even though you aren’t using it) and it will WAIT until it drops to at least 110° before continuing.
  • It will then re-prime the filament in nozzle 1 and purge a bit to get things flowing.
  • It will switch to nozzle 2 … but NOT re-prime (it will go through the motions as if it is about to re-prime and purge filament, but skip the step of actually re-priming or purging).
  • It will switch back to nozzle 1 and start printing.
  • It LEAVES nozzle 2 at 100°C. (I use the temperature menu to turn nozzle 2 down to 0°C to turn it off).

Since it will NOT re-prime an inactive nozzle (nozzle 2) this means the NEXT time you want to use that nozzle… the filament will be backed out quite a bit (because it always backs it out… but never re-primes it). I’ve done enough prints in a row that it ended up unloading the filament. So be aware that you might need to manually re-load or at least manually re-prime that nozzle if you haven’t used it in a while. And if you haven’t used it in a while… it’s a good idea to let quite a bit of filament flow through … make sure it’s producing nice clean filament because typically the first bits that come out are pretty rough looking (no good for printing).

Tim,

Thanks for this and your follow up email. I am going to go through the link below and double check all the points in your other email. Hopefully, I will be successful.

Troy

Aside from starting a print, is there any way I can control the lifting / lowering of the nozzles through the control panel directly, just to help troubleshoot? Also, I’ve answered what I could below in red.

Tim,

I have checked these connections. They are in place and the wiring matches what is in the instructions, but just observationally, the connectors appear to be very loose for what I would expect once they are fully seated.

I should note that I also would have expected nozzle 1 to raise when nozzle 2 should have lowered, but that didn’t occur either.

Troy

I keep wondering if there is any possibility of user-error … but it doesn’t seem like it. E.g. it’s possible to have wrong settings in Cura. If you really want to eliminate any possibility of this, you can use the USB memory stick that came with the printer. Insert that in the printer, navigate to the “sample_prints” folder and run the job named “vernier_v1.0_PLA.gcode”. (You will need to have pre-loaded PLA in both extruders. They supplied a bit of sample “LulzBot Green” filament and “Black” filament.

That reminds me… when you loaded these filaments and purged out a bit of material… did the nozzle lower for you when you loaded the filament in extruder #2? (it should have)

Meanwhile back to your question…

Yes, a couple of ways…

Using the Control Panel

  1. Pre-heat the extruders: You can use the printer’s menu system to pre-heat the nozzles to a reasonable extrusion temperature (e.g. while I normally “print” my PolyMaker PLA at 230°C, anything over 180°C is probably warm enough to test extrusion.)

  2. Manually extrude: Using the “Menu” -> “Move Axis” on the printer control panel, you can tell it to extrude a bit of filament. You can think of these printers as being “4 axis” machines in that the Marlin firmware considers the traditional x, y, & z axes … but also considers the extruder nozzle as being an axis (the E axis). This is why you can use the “move axis” menu to order it to extrude some material.

If nozzle 1 is down (and nozzle 2 is up) and you tell it to extrude (make sure you pre-heated it) say … 10mm of filament on nozzle 2, then it should automatically raise nozzle 1, lower nozzle 2 and then extrude from nozzle 2. You don’t need to manually ask it to change nozzles… just tell it to extrude from nozzle 2 and the raise/lower steps will happen automatically.

Using Cura

If your computer is connected to the printer via USB connection (e.g. you aren’t saving the files to the USB memory stick and physically walking it over to the printer … but are just sending the job via USB) then you can use Cura.

Within Cura, along the top of the Cura window, you’ll see a “Prepare” and “Monitor” category. Normally you work in the “Prepare” panel to setup the job. You can use the “Monitor” panel to monitor the job but you can also use it to directly control the printer. Here’s a screen-shot of just that sub-section of the monitor panel:

  1. From here you can “Connect” and once connected you can control things.
  2. Select extruder 1, pick a temp (e.g. 200°C) and click “Heat Extruder”, then select Extruder 2 and heat that one up as well.
  3. Select an extruder, enter an extrusion amount (e.g. 20mm) and then click “Extrude”. Do this with each extruder.

As you do this, you should see the print-head automatically switch nozzles by raising/lowering the nozzles as you switch extruders.

Using the Console

Another way to do this is with the console. This is a command line interface that opens a terminal session with the printer. You are basically sending direct g-code commands. While this might sound more complicated… there are only two commands: T0 & T1

  1. Make sure you are in the Cura “Monitor” panel
  2. Click “Connect” to make sure you are connected to the printer (if you weren’t already connected)
  3. Click “Console” and this opens the terminal window.
  4. Type “T1” and send that. This should switch to the #2 extruder (right-side) and will automatically raise the left nozzle and lower the right nozzle.
  5. Type “T2” and send that. This will switch back to the left side nozzle as the active extruder. The right side will lift up and the left side will lower down.

If you use this method you don’t need to pre-heat anything because you don’t need to extrude anything.

But you don’t need to use the “Console” in Cura to do this… you can test the toolhead by using the touch-screen control panel on the printer by just using the “Menu” -> “Move Axis” screen and telling it to extrude a bit.

There is a wiring harness that goes from the control board (actually it goes from the board to set of harnesses on the back of the printer – hiding behind an access cover – and from there into the wires that route through the plastic drag-chains that route the wire to the print head. At the print-head there is one big connector that plugs into the bottom of a logic board (the logic board is on the back side of the X-axis carriage). THAT logic board has more connectors on the left and right side… which connect the wire harnesses to the modular print head.

It’s possible that there could be a loose connection somewhere. It’s also possible that there could be a bad logic board.

I don’t think it would be a failed actuator… you mentioned that when you try to use extruder #2 … not only does #2 not lower… #1 does not lift up. It’s highly unlikely that two separate actuator motors would both be bad. This makes me suspicious of either a loose connection or possibly the Dual Extruder logic board (on the back of the X-axis carriage) might be bad.

Make sure you open a support ticket with LulzBot.

Checking for a loose wire is easy enough… but if you have a bad board you’ll need a ticket opened to be able to get that replaced.

Tim,

I follow your thought process and appreciate your skepticism. I also don’t believe I’ve made any errors, but have been at this long enough to never say so.

I will try to run the file “vernier_v1.0_PLA.gcode” and let you know what happens.

To your last question, no, nozzle 2 did not lower to load the filament.

I actually did heat up both nozzles earlier today and extruded some material, expecting as you note below, for the extruding nozzle to lower. Neither nozzle ever changed position, but each extruded when I provided the commands. I did this
through the change filament/load menu on the Taz Pro directly.

Let me run through your processes below and see where I get. I think I have a ticket open, perhaps you can confirm. Request 4750, attached. I actually thought you were responding due to this ticket.

Thanks,
Troy

Ok, so that pretty much answers that. When I load filament on my TAZ Pro, whatever extruder is being loaded will be “lowered”. If that isn’t happening, then something is wrong (this isn’t a Cura setting or something you are doing).

This means either a bad connection somewhere or a bad board.

BTW, I’m not part of LulzBot support (or an employee) … I’m just another owner like you (these are community forums). So hopefully support can get back to you. I’ve opened tickets of my own and my estimate is that it’s probably somewhere around 1/2 week response time (they are still backlogged on help requests).

My own TAZ Pro was having layer-shift issues (I also have a TAZ Workhorse and that printer is working like a dream … print after print of gorgeous results). I think I worked out that the X-axis carriage on my printer was over-tightened. There are self-lubricated bushing that glide along the bars. There are some screws that adjust the tension on these glide bushings.

The printer doesn’t have physical end-stops to tell it when it reaches the travel limit. It uses motor amperage draw to detect when it’s drawing too much power. But this means that if it feels resistance, it can false-trigger that it hit a stop and this will result in a layer shift on the part. I was struggling to get through any prints without this happening (I’d occasionally get lucky). Post adjustment (which I did on Saturday) I’ve managed to get through perhaps a 6-8 prints without a layer shift. I need to print something particularly tall to test the printer for hours on end to be sure.

This is to say… sometimes if there’s something you can adjust on your own, it’s better than having to pack it all up and ship it in for service.

That’s why I’d check for loose connectors. LulzBot connects the board to a test harness (not a real print-head) to test the wiring. After assembly they do a “burn-in” test that exercises the printer even before they load filament. After loading filament, they also print a sample calibration part that uses both extruder (and tests nozzle calibration). So presumably those actuators were working at the factory before it got boxed up and shipped. But shipping can involve a lot of bumping and jarring so it’s possible something just came loose if it did not have a strong connection. It could be a weak wire crimp or solder point that didn’t survive shipping.

Since your left extruder is stuck “down” and your right extruder is stuck “up” … it sort of suggests the mechanism that controls the actuators is where you’ll find the problem and not the actuator motors themselves. I think that’s the TAZ 7 Dual Extruder control board that resides on the back of the X-axis carriage … but LulzBot should be able to confirm that’s the part.

If you look at this page:

https://ohai.lulzbot.com/project/final-assembly/quiver/

Section 1 … 4th photo down … you’ll see a photo of the printhead sitting next to the board.

Section 11 deals with the installation of this board. This board lives on the back-side of your X-axis carriage. The main cable from the controller plugs in at the bottom. The connectors on the top left & right side connect to the extruders on the print-head (left & right side respectively). If that bottom connector has a poor connection it might explain both of your actuators not working correctly.

If you do manage to get the nozzle actuators working, you should print the vernier calibration sample part. This checks the alignment of the nozzles. The finished part looks like this (except if you use your sample filaments you have bright green & black):

This print is used to check the alignment of the red marks on the vernier scale against the black marks on the scale. Note that black marks are spaced just a tiny bit wider than the red (or in your case bright green) marks.

In addition to the vernier scales on X & Y axes … that black “button” shaped thing in the middle of the part is a short tower (about 1cm tall). It prints 5mm using the left extruder and the top 5mm using the right extruder. If the alignment is good then the walls of the short tower will be perfectly aligned all the way around. If you see any layer-shift between the two colors it means the axes aren’t aligned (so it’s another way to validate what you can read on the vernier scales for each axis.)

The gcode for this calibration job assumes PLA is being used in each extruder.

What you want to verify is that the center mark has the best alignment/match (as shown here). If not, you can run the auto-calibration cycle on your printer (it’s in the menu … “Menu” -> “Advanced Settings” -> “Nozzle Offset” -> “Measure Automatically”). This will use that 1cm cube on the front right of your build plate. The printer will approach and touch that nozzle from the top as well as all four sides … repeatedly (first time at a slow-ish speed… second time at a VERY slow speed) and will do this with both nozzles. It uses the data to compute the alignment differences between nozzles so that you get perfect prints when the printer switches active nozzles. Oh… it also measures backlash compensation on each axis so that it can compensate for part accuracy if approaching from one direction vs. the other.)

I happened to print this after I adjusted the X-axis bushing compression over the weekend “just in case” my adjustment shifted anything with respect to nozzle alignment or backlash. I ran the self-calibration process and then printed the part to confirm good results.

It doesn’t make sense to test that until your actuators are working (it will fail if the actuators don’t work).

Tim,

Thanks for all your help. I’ve forwarded everything I’ve done on to Lulzbot, along with video, so hope to hear back from them soon. I appreciate you taking the time to help me walk through this.

Cheers!

Troy

Hi Troy,

I recently had an issue with the second print head not lowering. I investigated it to find that the linear actuator that controls the movement was burnt out (not working) and had to order a new one which solved my issue.

BTW, on the LulzBot Facebook page, they announced they now have phone support open again!

For support call: +1-970-377-1111 ext 2

(You can find there post about it here: https://www.facebook.com/LulzBot/ )

They also posted about a batch of new Minis going out. Production is getting ramped back up!

Did you also experience the actuator for nozzle 1 not lifting? I’m not getting any motion from either of them.

I did not. My only issue was with nozzle 2 not lifting.