Taz Workhorse - Auto-levelling problem

I have been printing for about 2 years with my LulzBot Workhorse. Mostly smooth sailing, just the typical 3D printing troubleshooting.

However, a problem developed yesterday in the auto-levelling routine. The printer correctly finds the front left, front right, and rear right washers, but then fails to move left to the final (rear left) washer and just repeats the rear right. The printer thinks it has complete the procedure correctly and tries to move to print position, but since it is already extreme right, it crashes into the right side of the frame! (Luckily I got to the power switch before it could cause any obvious damage)

I have tried running G29 V4, and same issue, although occasionally (10% or less) it will complete correctly, after which it continues to print with very nice results.

I have tried updating the firmware, thinking my G29 instructions must be corrupt, but no luck. Any suggestions?

Does it move fine left and right several times in a row outside of the auto-leveling routine?

Yes, for example it will go to home position just fine. Manual movements work as well. And the odd time it does complete the autolevelling correctly (again about 10% success rate currently), it will then run a whole print job flawlessly.

The fact that the issue is at all intermittent I find very confusing, because I was thinking software at first, but intermittent software problems are kinda rare in my experience (unless it’s a matter of dropping communications, but I’m getting the same results if I print from SD or USB).

I’m no expert with printers, but in a general hardware sense, it sounds like a wiring fault potentially?

I was leaning the same way due to the intermittent nature, and because it occurs just after the print head moves to it’s furthest right position (the cables are at their most stretched here). I didn’t want to speculate in the original post in case it eliminated an option I wasn’t thinking of from discussion.

The next problem then is how to test/troubleshoot/fix? Which wires/cables should I be looking at? Is there continuity testing I can do? Are there replacement cables available I can order to test swapping them out? Hopefully someone who knows more about this machine than me can give some pointers there.

This is why I questioned moving it manually through the physical extents several times - to eliminate the wiring as a cause of failure. Move the x axis back and forth with the bed at the front, then do the same with the bed pushed to the back. The only way to catch intermittent issues is repetition. If you move from the limits manually 100x and it never fails, but fails 90% of the time when doing it with the bed probing command, you know that it’s likely a software issue.

Does it fail if you manually initiate a bed probe through the LCD directly?

When watching the probing sequence, keep in mind, that whatever prevents leftward movement may be happening after the initial movement to the left for wiping, since after that, it’s just up, forward, down, up, right, down, up, backward, down, up, left.

Gotcha, I will admit I hadn’t tried full travel manual movements yet, that’s a good idea. When I get a chance I will give that a try and see what evidence it adds.