Taz6 does not turn of the bed heater at the end of a print

I had a Lulzbot Mini, and at the end of a print when the model was presented to me, the bed heater turned off. It shortly cooled to room temperature. This is the behavior I expect.

My Taz6 also finishes a print and then allows it to cool before presenting it to me (i.e. moving the bed forward). The problem is that the Taz6 bed heater remains on after this. There is no way to turn it off in Cura (none of the head homing or motor-off options have any affect). Even if I could turn the heater off in Cura, I’d have to be there when a print finishes. I sometimes start a print any go do something else. I return to find that the print finished and the Taz might have been sitting with the bed heater on for hours.

What can I change in the Taz configuration that will turn off the bed heater when the print finishes?


I use Simplify 3D, and there is a chunk of G-code that is added before and after the print. In the chunk afterward, there is a specific line for turning off the bed. I would suspect that you are missing this.

Here is what is in mine:

M400 ; wait for moves to finish
M104 S0 ; turn off extruder
M107 ; turn off fan
M117 Clearing work
G91 ; relative positioning
G1 Z2.0 ; move the extruder up to clear work 
G90 ; absolute positioning
G1 Y0 F3000 ; move to cooling position
M117 Cooling please wait
M190 S50 ; cool down bed
G1 Y280 F3000 ; present finished print
M140 S0 ; turn off bed
M84 ; disable motors
M117 Print complete

The bed is intentionally left at the part removal temperature for your specific filament. If you allow your bed to cool to room temp, you run the risk of your part contracting and creating bubbles in your PEI surface.

You can alter your end gcode to prevent this, but you will be replacing your PEI more often: https://www.lulzbot.com/store/parts/lulzbot-taz-pei-sheet