Workhorse Bed Levelling Failure

Hi everyone,

I’m kind of stumped on this one so I would really appreciate any ideas you guys have.

I have a Taz Workhorse which is having a consistent issue bed levelling. It seems like it cannot get a reading when it touches the washer as it continues to press the pad down and then moves to a x-axis level, cleaning, tries to level, and repeats until it shows “Autolevel failed PRINTER HALTED Please reset.” I have included a video showing what is happening below. I have just replaced the wiper pad and can ensure that the nozzle is clean of any debris after also using the included scotch brite pad. I can also confirm that all connection points are secure. Do you guys have any ideas what would cause this sort of bed levelling failure?

You can see the video here - https://drive.google.com/file/d/1s-QduSNjBTs6wEZ2xTk39lUlTiZoRv78/view?usp=sharing

What version of Cura are you running? Your start g-codes don’t seem correct. I notice only the Y axis is moving. When I do this on my Workhorse I get a few wipes on the Y axis direction… but all some side-to-side wiggles on the X axis direction. Regardless… the wiper operation is separate from the bed-level operation.

As for the behavior where the nozzle pushes too hard… that occasionally happens to me. I’ve noticed that usually the first bed-level after power on works… but if I print subsequent parts, the next bed-level may fail.

I have yet to determine why… and am wondering how the continuity test works. (E.g. is it checking for a connected circuit… or is it measuring specific ohms?) It makes me wonder if my wires are solidly connected to the board … or if the firmware needs some tweaks.

I am using 3.6.20. The strange thing is I have run many successful prints prior with the same firmware and version of Cura. I haven’t touched the printer in about a month but previously everything was working great. It was quite a surprise.

When I start the print it starts by doing the wipe and then it moves to doing the bed level operation. It seems like the standard start up code but it just isn’t getting a reading when it touches the washer.

We have five workhorse. They have been a royal pain in the bed leveling and first layer consistency department. Two things I have found that were causing our major problems.

The stock steel nozzle threads on our machines seemed to be corroded which could lead to a poor electrical connection. Try a new brass or copper nozzle.

This was the big one. ALL five machines had loose heat brakes. They eventually started leaking and drew my attention. After tightening the heat brakes our bed leveling problems have been greatly reduced. The sensing wire for the bed leveling circuit is attached to the heatsink. Loose or bad threaded connections on the nozzle to heater block and the heat brake to heater block and heat sink will have an effect on the quality of the corner measurement.

Occasionally, I need to hit the nozzle with 1500 grit wet dry paper to remove hardened burned plastic. In those cases, the Scotch-Brite scrub just doesn’t cut it. Also, make sure the washers themselves are clean. Small layers of plastic can build up at the nozzle contact point.

Here is a picture of the plastic leak that led me to tighten the heat brake in the heatsink.

1 Like

In my case two days ago and in another users case with a mini you can use a multimeter to test continuity and narrow down where your problem is.

Test between the washer, its attachment point to the bed (a nut on the underside), the washer and the wire harness pin and the lead in the case.

You can also start at the hotend and go nozzle to the the zero sense pin in the heatsink and verify continuity and then follow it to the harness. The wire your looking for on your print head should be red.

I suspect nopick may be right about the nozzle but this may verify for you where the issue is and if there is nothing between the zero sense and the nozzle you have it.

On the aerostruder for the mini last night it was Pin 8. I don’t recall which it was on my Taz. In my case I had accidently disconnected the lead from the rambo board while testing another issue. In the case of the user with the mini he found that one wire had become twisted and nearly came lose from its harness and the zero sense wire was installed into the wrong pin port.

IF you have to go into the case…
I checked the instructions for building your machine under the control box assembly but didn’t see any reference to the lead plug in but as we use the same board on the TAZ 6 Mine plugs in here at the red box in the top center of the image:

Maybe someone with a workhorse can verify?

Hope this helps you narrow down your problem!

The tip of your hot end looked like it had some goop on it. I’ve had mine fail before when the tip was not clean. Also, I ran into a ton of issues with the cura version you are using. I suggest using the experimental version, that is the latest one…and its actually more stable than the “stable version”.

Oh wow, I have seen this crap on mine and did not pay attention to it. I took your advice in the other thread and went with a plated copper nozzle (I owe you a 32 pack of beer for that one :slight_smile: ), but when i changed it i noticed my heat break was a bit loose as well. I have not tightened it. I will be cleaning it up and tightening it tomorrow morning asap!

On a hunch, I considered that possibly the extruder tip is getting a build-up similar to the “seasoning” that builds up on cast-iron cookware. The nozzle looked “clean” … just dark.

So I grabbed a brass brush – I have one that is just a little larger than a toothbrush – and gave the nozzle a good scrubbing. (A bit of caution here because you don’t want the bristles to hit the wires.) I could see the nozzle was noticeable brighter after cleaning it.

After cleaning … the bed leveling was flawless.

1 Like

although slightly different, this is what i thought it was, it just was not making the connection. I had dealt with this when there was an excess of filament on my hotend. I clean mine manually before i start now with the red pad it comes with :slight_smile:

I do what virtual Tom does as well. Very carefully with a wire brush. This is a very delicate process because you can short something out, but it if you do it right, it’s fast and leaves the nozzle clean.

I really appreciate all of the suggestions. I will give these a try and update once I have a chance to try these.

I have no answers, but I am having the bed leveling issue and same error message of "Autolevel failed PRINTER HALTED Please reset.”. The kicker is that before this message the nozzlehead goes thru the motions of calibrating and cleaning the nozzle about 8 inches above the platform. This started happening after a good number of successful prints. Everything still looks clean and tight. Lulzbot support is of no help. What can I do to remedy?