Taz Workhorse Calibration Failure

I have been printing with my new Taz Workhorse for several months without issue. Within the last week, I started having calibration issues. The print head starts the process of cleaning the nozzle, then quickly into calibration. It hits the first calibration disk just fine. But when it goes to the opposite side, I hear a “belt skipping” thump, thump, thump, and the print head never makes it to the opposite side so that the nozzle lines up with the calibration disk. Of course, when it looks for the disk and hits the bed, I get the ubiquitous

Wot dat meen? There’s nothing in the Taz Workhorse manual that indicates how to “reset” other than cycling the power. But that doesn’t seem to fix the problem. I have tried running the auto-calibration and that didn’t help. Then I tired flashing the firmware again. This worked once, but not now. Is there a setting in the g-code that I can verify that the travel distance from side to side is properly set?

It sounds like something is physically keeping your printer from moving all the way over. (Duh!) But it doesn’t know that it’s failing to get to where it’s going. So you need to find out what is preventing smooth motion to the other side. this could be a belt issue or even some piece of plastic falling down and getting wedged somewhere. It could also be a loose pulley that starts spinning on the motor shaft at a certain point.

You might turn the machine off and move the axis by hand. If it’s is binding in the middle you need to see why and fix. If it seems to move freely then it is likely pulley, motor or driver related. If the pulley is tightly mounted, it could be a failing driver or motor (unlikely given that the issue seems to only happen at a specific physical position) or wear in a stepper motor wire that is causing impedance at a specific point due to wire fatigue.