Wrong toolhead detected


I have moved my Lulzbot Mini 2 from my PC to my Mac. My PC runs Lulzbot Cura 3.2.21.

When I connect on my Mac that has 3.2.32 installed I get a “Wrong toolhead detected” message.

This is a stock Mini 2, I choose the print head SE 0.5 Aero V2.

Can anyone shed light on why I am getting the “Wrong toolhead detected”? I tried on two different Macs.


The message is popping up due to a firmware update in 3.2.32. We changed the name of the firmware from “Marlin_Mini2_AerostruderV2” to “Marlin_Mini2_SingleExtruderAeroV2”. So as far as Cura is concerned, you do not have the correct tool head on there. (While in all reality, it is completely correct)

To fix this up go to Settings > Printers > Manage Printers > Upgrade Firmware > Automatically Upgrade Firmware. This will flash the updated version, and it will be recognized properly by Cura.

I would also recommend updating your PC to 3.2.32, as we have made a slew of improvements since 3.2.21. Cura LE Release Notes

Thanks for the reply.

I upgraded and reentered the EO value I have, which was 0 (unless I messed up) and the Z endstop offset of -01.24. The values also match on the Quality Assurance Record.

Now when I try to print I get “Homing failed PRINTER HALTED Please reset”.

Did I mess up the E0 value or Z endstop values? Unfortunately I now have a dead printer.


The issues seems to have been that the z-axis was already homed when it tried to home.

Moving the head down slightly solved the issue.

I could not use the console to move the head, it asked for it to be homed first. I had to power down and move by hand (not something I enjoyed), is there another option should this happen again?


This is how the Marlin 1.1.9 branch works, it was added as a general safety feature. Your printer has “max travel limits” set in the software, but it cannot enforce these until the printer has been homed. Once it knows the home position, it can safely prevent movement that would damage your printer.