Y axis Vibrations

Like many I have an issue and Lulzbot Customer Service is unresponsive. I know they laid off much of their staff and are in a business merger but the complete radio silence is disheartening. That being said I am turning to the community to see if anyone has any ideas because wallowing over no contact wont help me :wink:

Background: Starting in january of last year I bought my first 3d printer a lulzbot taz 6. I had some issues with the first one (a leaky hot end) and rather than try to figure it out I went back to the store I bought it from and exchanged it. The second one I got ended up having other issues (Z axis wobble) and I exchanged it as well. In March I got my current machine. It has not been without its problems but I realized that no machine would be without issues and I managed to work through most of them with help from support. Given the last date of exchange I have about 2 months left under warranty ( If they become responsive)

Current Issue: I now have a new issue I have not been able to figure out. Starting about 2 months ago my Taz 6 has developed a vibration when moving the Y axis. It is constant that it vibrates but seems to be intermittent between moving front to back or back to front that produces the vibration. It happens both during printing and when moving the axis with the front panel controls.

Video 1

Video 2

I did a lot of reading online and searching but have not been able to locate much relevant help. The vibration appears to be toward the back of the axis. The smooth rods don’t have any noticeable markings or any kind of bend, though they do leave slight streaks of color from the self lubricating bearings and I will get blackish colored deposits, which seems new to me but I may just not have noticed before.

What I’ve Tried:

I have used Cura LBE to ensure the firmware is up to date.

I have tried cleaning the smooth rods with a clean cloth. I removed the Y axis thumb screws, unplugged the motor and turned the whole assembly over to ensure I could access the full length of the of the rods. Wiped them down well and reinstalled. It was fine for about a half a print before it started vibrating again.

So I repeated the step and added in checking all the screws for tightness and making sure the belt was snug. It seemed a little loose so I tightened it a little but made sure not to over do it. I also put a small spot of blue ink on the edge of the belt where it met with the pulley when the Y was fully extended so I could tell if it was slipping (it’s not). Put it back together and a half a print later it started vibrating again.

And then:

The vibration was getting worse as time went on but I could still get decent prints when I stick to the center. Then the strangest thing I have had happen to date occurred…

While printing a prop, the printer lost track of where it was somehow. It printed back and right of center a quarter of the way through the print. After some spaghetti it built up enough of a base to even start solid printing again in the wrong location… I have NO IDEA what could even cause this… or if it is in any way related to the first issue. I am adding it in here because it could be a puzzle piece to see the whole picture… or it may be completely unrelated.

So… yeah… Please help!

This is a good one! I’m thinking perhaps your stepper motor is skipping. As if the stepper driver is receiving too much amperage and needs to be adjusted downward. This is easy enough to test on a cheap Chinese or DIY printer, I would assume this could be done on the Lulzbot printers too. The stepper drivers would be on the motherboard behind the screwed on cover. I’m getting a bit out of my comfort zone saying this may be your problem and what to do to fix it. Perhaps others in thus forum can chime in on this theory and you can begin some research on this.

Hey any path is worth looking at, Ill start looking for what I can on that. I did see 1 post where someone indicated they had to replace their rambo board but there wasnt alot to go on. I could swap the lead for the x axis and try moving the motor off a different controller… I think? Thanks for your thoughts!

I have had similar problem with two printers. In both cases it was a failing Y motor drive. Replacing the Rambo fixed them.

You can try scrubbing the smooth rods with green scotchbrite and IPA but that probably won’t help since you have already tried cleaning them.

That would be some fair troubleshooting if you can do it, the problem should move over to the X axis. If it remains on the Y axis then swap the motors and see if it moves over to the X axis. If it still remains on Y then something else is surely amuck. I say “if you can” because I know the waiting is usually very exact and tight. I certainly would want to replace a motor than the Rambo board. Also, find out if the motor drivers are adjustable, there should be a small screw on them to adjust the voltage/amperage. Be aware that they are very sensitive and the smallest turn of the screw makes a big adjustment, you would definitely need a voltmeter attached to the screwdriver as you make the adjustment. In fact, perhaps you can get the voltage reading from the drivers before swapping anything around, just to see where they’re at currently for our FYI.

@nopick @JoeBowler300 I think I just ruled out the Rambo. On swapping the X and Y axis the problem was still there meaning its something past the signal being sent.

I have just finished a scrub with a green heavy duty Scotchbrite Pad followed by another rubdown with a clean cloth to remove any bits of pad that may have hung around after. I will run it for a bit to see if the problem persists.

I am unsure how to check the voltage with a multimeter as its one of my tools I have yet to learn to use well. That being said I was able to follow these instructions to verify continuity. I have two friends who are electrical engineers, one of whom has built a 3d printer from a kit. I will reach out to them and see if either can teach me a bit more about the meter and how to properly measure the voltage.

I will look at moving motors only after I have exhausted other options (makes me nervous as I don’t know how to calibrate just yet).

Another thought I had would be rotating the berrings. They tend to leave streaks on the top of the smooth rods but not on the bottom or sides. As such I could try popping them out, rotating them upside down and see if maybe they have unevenly worn? Does anyone know how long they should last?

For that matter as a separate step I could try rotating the smooth rods?

Problem was still where? Still on the Y axis? If so then the problem is pointing toward the motor. As you say, the motor swap would be next after trying all the other things. Your friend who built his 3D printer should know exactly what I’m talking about with the motor driver voltage reference and how to check it. If you end up needing a new motor it should cost you under $25. Good luck with this! Keep us posted!

You can’t adjust motor driver voltage on the Rambo the same way can on a Ramps board or many of the chinese machines, for example. The Rambo doesn’t have pots on the driver or board for voltage adjustment. Rambo vref is set in the firmware. I think it can be exposed via the LCD controller but I don’t think Lulzbot has that feature on any machine.

If the bed moves freely by hand, swapping in a different motor would be the best next step. I have never needed to adjust vref on any of our Lulzbots.

Well that stinks! I wasn’t sure, thanks for verifying.

So to give an update I ordered a pair of smooth rods off amazon and a set of bearings from the original manufacturer.

The rods arrived first so I marked my old rods with a sharpie and replaced them. I put in the new rods and while they worked fine with no issues. It did make an odd sound when it moved along the Y axis like someone dragging paper along the smooth rods.

Once the bearings arrived I wanted to conclusively determine what the problem was. I removed the old berrings (NOT a process for the faint of heart. They are hammered in and needed to be hammered out which damaged the old bearings and risked the carriage getting deformed). With the new bearings installed I put the original smooth rods back in. 36 hours of printing later… No abnormal noise. No vibrations. Its like its brand new. SO… I still don’t know if it was the rods, or the bearings sticking. Time will tell if these wear down and it happens again.

On a very happy note, 2 days after I changed the bearings, Lulzbot tech support responded to my e-mail for help and asked if the problem was still occurring. Their radio silence has been broken! Even if I have voided some part of my warranty by taking matters into my own hands I am VERY happy to see them getting back on their feet and working through the ticket queue!

1 Like