Z-axis offset woes

Some genius zeroed out the z-axis offset on a Taz5, and the firmware has since been upgraded. The printer now tries to print well above the stage.

Unfortunately the current version of the firmware seems to have eliminated from Advanced Settings the ability to check or change the z-axis offset option (probably a good idea). So, I switched to the Cura-based approach as outlined here: https://www.lulzbot.com/learn/tutorials/Z-axis-offset (which, interestingly, doesn’t reflect the current firmware)

Sadly, the M851 command from the console returns nothing at all. To make sure it’s not my cable or the printer, I checked M501, and got the usual eprom dump. I tried it on a properly functioning Taz5, and same result - M851 returns nothing, while M501 works fine.

Does anyone have any thoughts on how do deal with this, or what may have happened to the ability to read the offset? Has the offset simply been eliminated from these printers? If so, how do I get it printing on the bed? The printer is effectively bricked at this point, unless I want it to print nice random birds nests of filament.

~ Will

The Taz 5 doesn’t have any software offsets for you to adjust.

You need to adjust the the Z end-stop trigger adjustment thumbscrew.

I did that. I bring it to exactly stage level when it’s homed. When it prints it does so a mm or two above the stage.

There used to be a z-axis offset in the Taz 5 firmware. It could be reached through Configuration / Advanced Settings (I know because I played with the setting once, and got exactly the behavior I’m seeing now.) The Lulzbot documentation says that it’s there, and explains how to change it, but those methods don’t seem to work anymore.

It sounds like you just need to adjust that a little bit more.

Is there still room to move the thumbscrew clockwise?

You may also want to start from scratch and re-level the bed completely:

I’m having the same problem. Very frustrating. And yes the bed has been leveled. Any solutions?

I loaded/installed the latest available Taz 5 single extruder firmware on Thursday and it printed without a problem so far. I did notice there is not a Z Axis offset in the LCD menu for that version(

any update or ideas on how to fix this? my taz5 has been running well for years and now this?!?!

wow. do I feel like a glum glum! The right side of my printer was WAY off, as in many mm too high. All better now. good luck!

has anyone found a solution to this problem, My printer is printing so close to the bed that no filament is allowed to flow, sure would be nice to be able to change the z offset.


The directions above show how to level the bed from completely from scratch.

Follow the entirety of these directions and your bed will be level and your Z-offset correct

think this has anything to do with why one side is off? a video i made https://youtu.be/k7jnekVjxw0

Prenote on the youtube video, I don’t think that is the reason at all. A proper bed leveling levels relative to the bed and it can be quite a bit off and still have perfect layers if it’s done correctly.

Also, just email lulzbot support and ask this question - they get back fast and are helpful. They might solve this better than what I’m about to say.

I think I have a general answer for you from my problems/issues (in other threads), I’m quite annoyed by this as well. Take this with a grain of salt because I’m using a Taz 6 with a dual hotend, which is it’s own nightmare. And because I prefer to use simplify3d which has an offset command easily implemented for each print to change that offset.

First thing to note is that this is supposed to be fixed by the autolevel sequence, so check what’s wrong with your leveling first and see what might be misprobing (and if it works fine but doesn’t offset right then it’s probably hidden in arcane firmware somewhere, but I’d still try reflashing it).

If all of that is on the up and up and doesn’t solve it, here’s a place you can start - but be VERY careful and have your finger on the off button, I’ve crashed all my printers into the glass HARD at various times and this could be a way to do that. Go to your start sequence, in cura it’s under printer, machine settings, then look at start gcode. I don’t know what your printer has first, just the general strokes, so you’ll have to experiment and figure out the start sequence gcode. Look for the G29 command, the probe sequence for autoleveling - or at least the G28 Z for leveling on the Z. You need to figure out what height your z probe goes to after leveling, then insert the command “G92 ZX.X” and put in an adjusted height for what it should be vs what it is (even better if there is another command using that but it is just off). This command alters where the printer thinks it’s at. For example, my Taz probes the Z, then returns to 15.5 height. So I take the print head to the center of my printer, lower it slowly, and find that it is at 0 bed height when the printer reads 0.5. So I added in “G92 Z15.0” to make it realize right after that that it is 0.5 lower than it thought. And it’s definitely better to err on the side of HIGHER and slowly get closer by printing over air than too low and smashing into the plate.

And all that’s thrown off if the leveling sequence is often thrown off, so if the Taz 5 has it (as I think it does?), you should tune it and make sure all the connections and stuff works as it should before doing all this.

Hope that helps!