Z offset problem

I installed a new build plate which is .26 higher than the leveling washers. When I go to probe Z offset I raise it from -1.20 to .26 through configuration, save the change, and reboot, but nothing happens. It’s showing my change through M851 but the height doesn’t change. No matter what I do Z stays the same! I add, subtract the numbers but nothing happens. It’s like the EEPROM is turned off!! I loaded the stock Marlin 1.1.9 then 2.0.8 same thing! This has really got me stumped…

If you could provide clear steps on how to recreate exactly what you are doing we can provide some feedback on that. Some other information that would be nice to know is what printer and tool head are you using? What firmware is loaded onto the printer and where did it come from?

I got something similar working correctly as shown in this video.BuildTak FlexPlate on Lulzbot Taz 6 - YouTube

Settings are at the very end and in my screenshot here.

Are you using octoprint or something else to send the G-Code to the printer? Did you do M500?