Adventures in ExtruderLand

I put together this post with my experiences with various extruder builds and repairs

I’m still in the middle of building and testing these things as mentioned in my post and have a few questions.

I built a “Fangtooth Guppy” 12v which needs a dedicated fan for the heat sink. Where should I plug this into the Rambo board? In the fan for the second extruder? I would like to keep that open if possible.

Also I bought some of these cartridges I wired one up and tried to run the calibration routine, but it heats up so slowly that the routine times out. If I leave it connected long enough it will eventually reach up to 230c, but if I turn on the cooling fan the temperature drops off dramatically and won’t maintain temperatures above about 120c with the fan running. Any suggestions for using this type of heater?

Lastly where do I find the CAD files for the extruder parts? I would like to make modifications to the Fangtooth extruder body, idler, and mount.

Yes you can plug the heatsink fan into the second connection. The newer versions of Marlin now support heatsink fans and will turn the fan on after the extruder reaches a certain temp. You’ll have to make adjustments to Marlin to get it to work. The rambo board also has a 12v aux. connection but you’ll have to solder the headers onto it. If you look at your board I believe it is labeled X30 and it is right by E1 motor connection. As for your heater cartridges what is the Max PWM set to in Marlin for your hotend? Are you using the stock Taz Marlin firmware? Here’s a pic of my reprapdiscount metal hotend/extruder that I built.

That is an interesting looking mini blower fan you have setup. Where is that from?

I’m still running the stock Marlin firmware, I haven’t dove into the printer firmware yet. What would I need to change to support the hexagon heater?

Open the Configuration.h in Marlin and look for these lines:

// PID settings:
// Comment the following line to disable PID and enable bang-bang.
#define PIDTEMP
#define BANG_MAX 220 // limits current to nozzle while in bang-bang mode; 255=full current
#define PID_MAX 225 // limits current to nozzle while PID is active (see PID_FUNCTIONAL_RANGE below); 255=full current

The stock firmware is setup for the buda 2.0c so the BANG_MAX is set to 70 and the PID_MAX is 74. I would raise this values up, save the file and reflash the firmware. Once the firmware is reflashed you’ll want to run PID tuning.

The mini blower is the same one they use on the Lulzbot Mini. It is a little too small since it doesn’t blow air on the entire heatsink. I’ll have to find the part number and website I ordered it from and get back to you.

Are you using the stock heater that comes with the Reprap discount hotend? I’m pretty sure mine quit on me last night when running calibration. I set BANG_MAX or PID_MAX to around 120 and ran calibration once and it seemed to heat up pretty fast and hold temperature ok.

Then the stepper motor wouldn’t move, it was like it had no torque. It would move if the latch wasn’t closed and there was no force on the gears, but you could easily cause it to stop with one finger. I tried a second stepper with the same results. I was using the marlin source from Github at the time so I decided to switch to the copy on to see if it was just some strange setting I couldn’t seem to find.

After re-flashing the extruder won’t heat up. I’m not sure if the extruder stepper is working again as I was pretty frustrated by that time and quit for the night.

Can you make sure you’re reflashed with your stock firmware and make sure your original toolhead is connected. You should see a temp of about 20c or so on the hot end thermistor. Try to set a temp of 50C on the hot end- if it’s not able to do so and you have access to a multimeter test the resistance of the thermistor and heater resistor.


to revive this post-

I have some trouble fixing up my hexa on a TAZ 3. It is a problem with Z movement
here are some videos on that

  1. This is with stock TAZ 3.1 firmware showing it works fine-

  2. This is with TAZ 3.1 fangtooth firmware showing troubles in Z movement

I think I am getting too much current or something. Now I go step by step in changing configuration.h file from stock to fangtooth. To see when does it start making problems. First I will change MAXTEMP and thermistor…

If anyone has an idea or a solution I would be glad to hear.