AutoHome issue on new TAZ 6 Firmware


Just updated firmware and the toolhead crashes when trying to autohome. The nozzle touches down on the housing of the Z limit switch when homing the z.
Also unfortunately, the toolhead moves in the x and y on startup further crashing the already crashed toolhead, which has created some play in the toolhead carriage.

Anyone else experiencing this?
I tried the new firmware on a different printer and it homes as expected so the mystery deepens.
Vid: AutoHome Issue - YouTube


Reflashed the new firmware and it works. I don’t know what the issue was but if anyone else has this issue try updating the firmware again.

Please provide the exact filename or some other way of identifying the firmware you downloaded.

At this point there is no way I could. It was the first of three printers I updated. The first printer messed up as I described above and the other two worked, I went back and redid the first and then it started working.

My process was to open the newest Cura LE and connect the printer via USB and then automatically update firmware in the printers tab.

I’ve narrowed the issue to one toolhead. It seems that the nozzle on this toolhead is in a different position compared to different toolheads (all standard .5mm toolheads). This didn’t cause an issue on old firmwares because it seems that the “y” position when zeroing was closer to the center of the z limit switch.

On the new and old firmware the positions when autohoming are X -19 Y258 Z3. The Y on the newer firmware seems to be ~5mm closer to the edge of the limit switch (towards wipe pads). Is the (0,0) on the new firmware different? I’ve flashed .5mm toolhead firmware and selected it on the printer too.

I am talking about version and

Photos attached of where the x and y zero to while both returning the same coordinate, ignore the dirty hotend, had a print detach.

It might be worth moving the y axis in the corresponding direction so that it hits more in the center.