Cura 2.6.52 is excessively slow!

I have a dedicated laptop for my Taz 6. It is a Core 2 Duo at 2GHz running Windows 7. It is a pretty old laptop, but it has never run a program excessively slowly before.

I just downloaded the new Cura 2 version and it seems pretty nice except for two things. It takes forever to load, and it runs VERY slowly. That is almost tolerable except for the fact that printing via USB is un-usably slow. When printing from USB, the print head stops and starts, evidently waiting for a new instruction to arrive from the computer. If I save that G-Code to the SD card, then it prints from the car just fine.

The old Cura version works briskly on the same setup. Printing via USB is no problem at all.

One other thing that I do not like is that there is no screen (that I can find) that shows the results of the self-leveling procedure. Occasionally I get very odd values which indicate a failure of the leveling procedure. This is rare, but it tells me that I need to abort and try again. Without that readout, then the print could proceed and give poor results after wasting filament.

Any suggestions for these issues?


You do not say which Cura 2 you are using, but you should have a Console button under the Manual control section that will be what you want.

Hello ARhodes01075,

Thank you for the feedback, we truly appreciate it.

This is one we had reported yesterday, and looks like we have a fix in place on our developmental builds:

You can find our latest developmental builds here: The specific build with this fix is 2.6.54

As for the slow loading, it is something we are looking into! The profile management system is much more powerful in Cura LulzBot Edition, and can take a bit longer to load.

As for the slow loading, it is something we are looking into! The profile management system is much more powerful in Cura LulzBot Edition, and can take a bit longer to load.

It is good to hear that slow loading is being addressed. FWIW, the Ultimaker version of Cura 3 (three, not two), loads briskly and seems to be more responsive while being used (i.e. popping up and filling menus, and other panes) than Cura 2. It seems odd that there is Cura 2 seems so slow in general.

I will load and try out the new development version of Lulzbot Cura. However, I suspect that the very slow responsiveness in general of this version of Cura 2 may cause slow USB transfers too.

I like the additional of all the settings of the printer that is given in Cura 2. When I wrote the G-Code to the SD card and printed from the card, it worked well. The slicer seems to be working well. The only difference I could see was the first layer line width which was 125% in the old Cura, and now seems not to have a specific control in Cura 2. This is not a big problem for me.


Hopefully 2.6.55 is a build that also includes the fixes from 2.6.54 that you mentioned. I tried it. Not really any different regarding printing. It still was pausing as it drew the scalloped edge of a part. The fill action seemed to proceed smoothly, the problem was drawing the outer edge.

The keyboard and mouse responsiveness seems about the same as the earlier build I tried: Slow. If I were to type an entry into one of the material fields it would take maybe 0.25 to 0.5 seconds to show each character. It seems like a full seconds, but it is not THAT slow!

Again, writing the same G-code to a SD card and printing from the card results in normal printing functions.


I think I have the same issue. I just installed Cura Lulzbot 2.6.6 on my TAZ 6
The printing is slow and “jumpy” (pause then print) on curved edges. The extruding is
also uneven with little blobs.

I’m using a laptop connected to via USB to drive the TAZ 6. (Intel i3-1.9G/2-core/4GB/SSD running Debian)

Cura 31.3 worked quite well. I upgraded because I bought the new Aerostruder
(I have not installed it yet) I’m still using the original TAZ Single Extruder Tool Head v2.1

This is very discouraging. I stopped the print because it sounds like it is hurting the printer.

Does any have any idea what is going on ?


I have 2.6.66 and Lulzbot MINI

I have observed the very slow loading, and due to someone complaining about bad performance when printing even on 2.6.6, I do not dare update, and will stay with the old version.


Slight correction, I’m using the newest Cura 2.6.66. I uninstantiated this version and reinstalled Cura 21.08

I did partial prints of the rocktopus, image attached. The 2.6.66 version is pretty bad (on left)
the 21.08 is perfect. Same laptop, same printer, only difference is the new version
of Cura

I agree that Cura 2.6.66 is SLOW even on brand new water cooled i7 87ook with gobs of RAM. To print I save to SD and always print from them. Therefore the print quality has been excellent on my Taz 5 with the new firmware and associated Cura. It was a strong improvement.

Despite overall positive impressions, I have to believe there is a bug in the code though. Nothing should run this slow. Video editing software and heavy lifting in CAD is faster.

I also appreciate the better support generation in CURA 2.6.66. It works much better. Thank you. I look fwd to the fixes.