Cura 3.6.18 update profile from current settings CRASH

Reproducible and annoying as hell. I moved from Simplify3D.

Not only do I not understand how to get a profile to work with a newly added material (I guess thats my problem) but if I duplicate a material, change settings and try to apply those changes in the profile manager, as soon as I press the button, the app shuts down with a hard crash.

Sorry to hear of the difficulty you are having with Cura. It sounds like you may need to clear your cache in Cura. You can do this by selecting your operating system and then following the upgrading section of this guide:

Keep in mind that if you do have any custom material profiles in Cura, you will want to back those up as clearing the cache will erase them. I hope this works out for you!

I have had the same problems with Cura LE. I have only really used Cura LE - I wonder if this behavior is the same in the standard version? I haven’t figured out exactly what triggers the crashes, but it seems that different versions of the Cura LE fail in different ways. I installed 3.6.15 and it would crash when making a profile. I downgraded to 3.6.13 and it would crash when trying to update a profile. Finally downgrading to 3.6.8 worked as expected. I just recently upgraded to 3.6.18 and am having no problems either. I always follow the proper installation procedures by wiping out the two cache locations so I dont know whats up. It doesn’t really make sense that such a basic function of the tool would have behavioral inconsistencies leading to catastrophic failure (crashing) like this. Running on Win10. I was running on Win7 a few months ago and noticed other odd behaviors so again, compatibility issues in the works?

It seems that the problem is related to a dual extruder printer machine profile and doing something with a quality profile on one extruder that conflicts or something with the quality settings on the second extruder, or vice-versa. I even tried recreating mt materials and profiles instead of importing them thinking it was a version incompatibility - but it still happened.

Anyone got any ideas why this happens, or anyone using the standard Cura ever experience this?? Again, perhaps we are operating with profiles in an incorrect manner?

Thanks Noah. I did this on the initial upgrade (using Windows). I find the app to be VERY unstable. I get crashes in the monitor also. I use Octoprint, so it doesn’t impact my printing activity, but it IS annoying. Additionally, it takes FOREVER for the app to load. Talking like 5 minutes.