Cura 3.6.22 will not load in win 10

I deleted 3.6.20, so I could do a clean install of 3.6.22. After downloading and installing, I get a message

cx_freeze: Python error in main script (traceback unavailable)
Error in sys.excepthook
Exception: cannot import name ‘Application’
Original Exception: No module named ‘sip’

After repeating three times, I gave up. I don’t see any way to download 3.6.20.

Try here for past versions…

http://download.lulzbot.com/Software/cura-lulzbot/

Could you give me more information, what OS are you running? Did you remove the cura folders in app data roaming? Is there a process still running with a name similar to Slicing Engine for Cura? What printer/toolhead are you using?

This worked. Thanks.

Even though I got 3.6.20 running, the problem with 3.6.22 needs addressing. I am running Win 10 on a Toshiba portable. I got error messages all the way through the process. During the download I got a message there was something wrong (forgot exact message), implying a virus or something - “do you want to continue”. I replied Yes. Then a message would appear from windows saying the file was not approved, did I want to continue - Yes. then I would get another message saying 3.6.2 was still installed, did I want to delete it and continue - yes. Then the final message about Python would appear.

I repeated this process at least 4 times. Delete 3.6.2, then download again.

Did you remove the cache folders in %appdata%? To get a clean install you need to remove those folders as well. SIP is a python binding library, the error you are getting is generally because it cant find the folder that it wants, it can be resolved by finding the folder which has the incorrect name and renaming it.

Yes, I did. After searching Uninstall app, I got two such folders. There was a second %appdata???% folder that I removed also.

So lets start from the beginning here. The first step is to open the control panel open uninstall a program under the programs icon then remove cura-lulzbot 3.6. While that is uninstalling you open a file explorer and navigate to %appdata%. Once you are there highlight both cura folders and delete them. Once cura has uninstalled we want to make sure we have the latest cura installer, double check this by going to CURA LE . We then want to open and follow any prompts, we are aware that Windows is not trusting of this installer. If any error pops up could you please screen shot them and upload so that we can see them.

Unfortunately, after having spent parts of two days fighting with it and I have been able to successfully reinstall 3.6.20, I have run out of time to go back and fight with 3.6.22 again.

However, the procedure you describe is what I did, except the Lulzbot web site is completely confusing about finding current and past apps. I had to go ask on the forum and then go outside the Lulzbot website to get to a downloadable 3.6.20. That is not acceptable.