Cura 3.6.3 "Z-Hop" on Nozzle Switch

I am not sure if the term “Z-Hop” is appropriate here, but I noticed in Cura 3.6.3 that whenever I switch nozzles, the tool head raises up 1mm, then lowers down to the proper layer height once the nozzle is ready. Cura 3.2.27 did not behave this way and I cannot find a setting that controls this. The problem with it raising is that it allows the nozzle to ooze. On nozzle switches, I insert code (that is also not working properly, see other post :angry: ) that turns the fans on full blast and waits until the standby temp is reached on the inactive extruder. In Cura 3.2.27, the head stayed on the previous layer height and prevented oozing. This worked very, very well! Now, I always get a little blob where material oozes out before the nozzle cools down enough. These blobs tend to get dragged around or cause collisions on the next layer. Super frustrating.

Is there a way to stop this extra behavior? I thought that there would be a setting that prevented tool head lift on nozzle switch, but there is not. I read that other slicers that do this have a control, so I am hoping that there is a way to do this in Cura.

G1 X156.442 Y152.063 E94.7701
G0 F10500 X156.587 Y152.208			//go to safe
G1 F1500 E79.7701				//retract 15mm
G1 F180 Z2.43					<- go up to next layer height + 1mm? -- I WANT TO REMOVE THIS
G92 E0						//reset to 0
;End E1
M106		//Fan full speed
M109 R175.0	//wait for temp
M107		//fan off
G92 E0						//reset to 0
;Start E2
M109 S220
M104 T0 S205
M106 S76.5
G0 F10500 X143.442 Y150.729 Z2.43
M104 S225
G1 F180 Z1.43					<- go down 1mm (at next layer height) -- I WANT TO REMOVE THIS
G1 F1500 E15					//purge to 15mm to undo Nozzle Switch Retraction
G1 F1200 X132.213 Y139.5 E15.2956		//proceed ...
G0 F10500 X133 Y139.5
G1 F1200 X144.229 Y150.729 E15.59121

I found the option. Its called “Z Hop After Extruder Switch”, but it is only visible if “Z Hop When Retracted” is enabled. Z Hop After Extruder Switch was enabled, but should have been defeated due to Z Hop When Retracted was disabled. This behavior seems odd.

I was able to get it to operate the way I wanted by:

  1. Enable “Z Hop When Retracted”
  2. Set Z Hop Height to 0mm
  3. Disable “Z Hop After Extruder Switch”
  4. Disable “Z Hop When Retracted”

Since these options are per extruder, you need to do it for both.


G1 F1200 X133.699 Y150.014 E29.85095
G1 F1500 E14.85095			//retract 15mm
G92 E0					//reset to 0
;Extruder 2 End
M109 R180.0
T0					//switch extruder
G92 E0					//reset to 0
;Start Extruder 1
M109 S205
M104 T1 S0
M106 S246.9
G1 F1500 E14
G0 F10500 X146.699 Y150.014 Z5.18	//move to next layer
G0 X146.699 Y152.19			//proceed ...

To me, the operation of “Z Hop After Extruder Switch” should be disabled if Z Hop is disabled or made into an operation independent of Z Hop, and should not be enabled by default and hidden away in an option that is not being used…