Cura2 materials locked (settings grayed out)

I installed Cura2 today (2.6.52) on Mac OS 10.12.6, and ran into a problem where I can’t remove or change settings on duplicated materials (greyed out).

  1. I installed 3 printers TAZ6, TAZ6 flexydually, and Lulzbot Mini.

  2. I selected the printer menu next to the box -> mange printers -> Materials and duplicated the ColorFabb XT profile 4 times and made a temperature change, removed one and renamed one of them FormFutura HDGlass

  3. I added two items to the start G-code for the lulzbot mini (M92 and M851):
    … snip
    M117 Heating… ; progress indicator message on LCD
    M92 E885
    M851 Z0.15
    M109 R{material_print_temperature} ; wait for extruder to reach printing temp
    … snip

  4. I saved gcode file for a test print

  5. I added printer Lulzbot mini flexystruder

  6. I selected the printer menu next to the box -> mange printers -> Materials

Now I can not change any of the 3 duplicated profiles or remove them as “remove” and “settings” are greyed out.

I tried restarting Cura2 without any change. Any ideas before I wipe and re-installe Cura2?

Hello jlund,

Thank you for the report, we truly appreciate the feedback. This one was reported to us earlier today here: and is currently being worked on here:

Feel free to sign up as a follower and get the latest update!

Ah, thanks. Yes that was Windows and this is Mac OS as well.

I will go back to Cura1 and look forward to the Cura2 material handling being solved. I am grateful for the new features and general step up with Cura2 and look forward to using it in the future.

If you are interested, there is a workaround at the moment while we solve the root issue.

In materials manger Duplicate a material, this will now show up at the bottom of your list.

You can edit, rename, and change all aspects of this material until you restart the Cura program.

Once the program is restarted, you will not be able to edit that material profile (for now.)

So if you have your parameters ready, you should be able to push forward for now :wink:

Thanks, but there are more bugs.

When using a copied and modified material after loading a model, choosing print resolution high, standard, quick that menu suddenly contains a ton of the same options 0.25 mm 0.25 mm (etc.) then lot’s of another choice etc. also a lot of repeated mm options that do not match any of the 3 options that was supposed to be there - It’s unusable as there is no way of guessing what is happening.

We need to run an in-house print shop on the Taz 6 we just bought.

I gave it a go at home on my mini, and no no no, there are way to many bugs to report decently within a reasonable timeframe.

It crashes a lot, starting up I get warnings that the program is probably crashed, ignoring those at every startup it asks if it should accept incoming network connections, suddenly the just loaded model can not be moved around on the plate and it takes more than one restart to get it going again, when scaling a model it is scaled away from the build plate, it then will not lay flat - when lay flat is activated instead it places the object at an angle (attached).

The best I can say is that I got an excellent test cube out of it after a clogging that normally does not happen.

Having been very happy with my mini, I recommended a TAZ 6 to my workplace and they download this.

There is a lot of promise there, but if it really is necessary to force the entire customer base into beta testing this, it would be decent to warn people and provide an alternative option for when they grow tired of their new Lulzbot printer !?! :bulb:

This is a really bad problem for me too. Luckily I had a profile already selected that I could copy and change the name on. This really needs to be fixed or explained. Once you modify a single material, Cura essentially becomes unusable!

Also, I’d recommend Lulzbot better structure the materials (like Ultimaker does):

  • Mark all the Lulzbot materials with a “Lulzbot” vendor so they show up in a separate section.
  • Create generic entries for all the key materials (PLA, ABS, etc.) with the “generic” vendor as starting points for other vendor’s materials.

Finally, can’t you guys get on the Cura core team instead of forking it? It would be nice to be moving to V3 and staying current with the mainline updates and fixes. Seems like you are putting yourselves through a lot of extra pain. :slight_smile: