Getting into 3D printing again with old AO-100, need help with config


I’ve been away from 3D printing for almost 7 years. During all this time, my AO-100 has been collecting dust. :roll_eyes:

I know that it’s quite an old 3D printer, but before deciding whether I would be better off getting a new one, I’d at least like to try getting this printer working again. But I’ve forgotten a lot about all of this!

I’ve downloaded and installed the last available version of Cura-Lulzbot for Ubuntu, and there is no available profile for AO-100/AO-101 printers.

I think I’m good for the XYZ print settings, but the rest of the settings for the printhead, start/end gcode and nozzle XY offset are what I don’t know what to set.

I’ve got the original Budaschnozzle, set up for ABS.

Any help would be appreciated.


Hey, I found the Git repo for CuraLE. Would I be able somehow to find the AO-10x definition by digging deep into the git history (something I’m not very familiar with), or was it never added to the Lulzbot Cura version?

Note of caution: I have not used to tried to recreate the environment used with the AO-100s. My suggestions would be to look through the “old” cura le and im also going to point you to one of our download websites.

Like I said I don’t know the state of the software or how it functioned.

“Old” Cura LE

Thanks, but I already checked both links. I also found the same 2012-Q2 directory on a MicroSD card I got with the printer.

As far as I could find, Cura LE never had profiles for the AO-10x series. As for the Printrun/Pronterface source, I cannot figure out where in all those files I could find the missing settings. I was able to find the print bed dimensions in the script, but that’s about it - and I already had those.

I tried running the Printrun version from the 2012-Q2 directory (on Ubuntu), but it was too old and the UI was missing most elements. I ran current Printrun from source; it works well and the default settings seem to be adequate. I wish I could use Cura-lulzbot as it is more modern, but I haven’t found where I could set the moving speeds for XYZ. It tries to move the Z axis too fast, the stepper motors jam and the whole setup makes a loud honking sound for a few seconds.

But now I have another issue… I’m making a new topic.

I found how to create new machine definitions through json files. I’ve been struggling with it and wasted a lot of time without success. Meanwhile I was still not 3D printing, so for now I reverted to the most recent version of Printrun along with PrusaSlicer, which is very nice.

I hope to give Cura-lulzbot another go at some point.