Help with Printing

Hi. I am new to 3D printing and trying to use the Taz 4 in a high school classroom with my students. We are currently using Pronterface and Slic3r. We have tried modeling parts in Autodesk Inventor and saving them as a .stl file, then using Slic3r to convert it to gcode, and finally bringing it in to Pronterface. Once we import it in to Pronterface it takes an extreme amount of time to load the part before it ever begins to print. We tried to print something yesterday and it ran all night long but never printed. It was still processing the code when I returned this morning and hadn’t printed the first thing.

Is there a problem with my process or is this common? I have been frustrated with this entire process and haven’t been able to print much of anything. We have even tried downloading .stl part files from and using premade items but the problem still persists. Can anyone provide me any assistance?


On Pronterface screen, what’s the Baud rate set to?

Top of screen where you pick your Port, then there’s an “@” then a window. What’s in that window after the @ symbol?

It’s set at 115200

I tried connecting at different numbers and it never would connect. It showed a lot of foreign symbols on the screen and did not connect…

Okay…maybe back up a few steps.

Are you using the proper Slic3r and Pronterface versions? The ones suggested by Lulzbot. Not “experimental versions”, “beta test versions” or something like that?

Are you using the Lulzbot provided configurations for the material you’re using? ABS or PLA? Maybe start with the “fast” version?

What OS is on your computer? Windows 7 or 8? XP?

Sometimes complex parts take a while to convert to gcode in slicer, but I’ve never had an issue getting gcode to load into Pronterface.

Also - from your comments it almost sounds like you’re expecting an automated process where once the gcode loads into Pronterface the print will start on it’s own? Am I reading that into what you’re saying?

Have you tried printing one of the parts on the SD card that came with your Taz? The octopus? Pliers?

I used the stable versions when I installed the software.

Also, I have been using the medium abs configuration in Slic3r that came from the Lulzbot website.

I am using Windows 7 that has a 64-bit OS

The gcode does take a while on some of the items I have tried but that hasn’t been my issue. I was trying to make a snowflake ornament for our department tree at the school and after we modeled it in Inventor and exported it as a .stl file, we opened it up in Slic3r and converted it to a gcode file, then I loaded it in pronterface around 12:00 PM yesterday and left it all day and all night. When I came in to work this morning it still had not printed anything and was still scrolling through lines in the pronterface screen. I have attached a screenshot of the numbers it scrolling through. They are all T:2xx.xx numbers…

I’m not sure how long it is supposed to take before the gcode loads and printing begins, but 20 hours yesterday seemed like more than enough time for the part. Maybe there is something I am missing or just doing incorrectly.

Here is the screenshot.

Wow… :open_mouth:

I work with Solidworks. So not sure what’s going on. When you save your part file to stl format, does Autocad give you any options regarding the “resolution” of the save?

Is Slic3r telling you about “errors”?

Are you sure you’re allowing the entire gcode writing sequence to complete before you try to load gcode file into Pronterface?

I’ve had gcode files take upwards of 30 to 45 minutes to complete in Slic3r.

I’ve never seen the gocode displayed in the window your attachment shows. I simply click on “File” then click on “Open” then select the gcode file I created in Slic3r. Everything usually loads into Pronterface in a minute or two.

What steps are you following once you click “export gcode” in Slic3r?

Would you care to attach your snowflake stl file?

Try downloading the small octopus gcode from here:

It should literally take seconds to upload that gcode into Pronterface.

I’m wondering if your origin, and x, y, and z axis are messed up in your stl file. :question:

See if you can load the stl file I attached. A 30 second snowflake from me and solidworks. :mrgreen:

That should take seconds to load into Pronterface. Seconds.
snowflake.STL (23.3 KB)

I finally got it to work after reading your post. I had been using the “Load File” button instead of going to “File” and then “Open”. No wonder none of my files were working. Any clue what the “Load File” button is for?

But I am successfully printing the snowflake now and will try several other parts within the next couple of days.

Thank you for all the help!