Mini Firmware Update confusion

Greetings, new to 3D printing world, just got my LB Mini and did the Firmware update but was confused on the step about having to reset the E0 setting. Is this something I need to actually do or is it part of the firmware? How do I actually set that if needed. Thank you.

The stock firmware uses a default value for the extruder E-steps value, which is the average stepps for that size hobbed bolt in the Extruder head. When your specific mini was built, Lulzbot ran a calibration routine on that hobbed bolt in your hotend to generate a specifically tailored e-steps value that is exact for your machine. Without that value in place your prints will be close, but not correct. The issue is that to extrude exactly 100mm of fillament, your hobbed bolt needs to turn a specific number of times. Each rotation it turns is devided into “steps” which essentially act as divisions of the rotation that are able to be certain stop points, The stepper motor with the smaller gear needs to turn a set number of steps to extrude that amount of fillament, which is where the e-steps value comes from. E0 is Extruder 1. A mini doesn’t have an E1 (extruder 2) value, but it uses the same firmware as machines that can have dual extruders.

Your E-steps value should be on the manual or a build sheet that came with the printer. If you don’t have it it is possible to recreate it.

If you have that value wrong, you will either over or under extrude when printing. If the value is too high, your motor will turn too many times, so when it thinks it is extruding 10mm, it may actually be extruding 13mm, etc.

To set that value, you can go into the advanced settings of Cura somewhere and just enter the new value.

Appreciate the additional information, helpful in learning about all of this.

Is this where I would need to make the setting adjustment?


It states that “0” means it refers to the profile, based on what you have shared I should adjust it to the sheet that I received with the unit (in my case it shows 833

833 is the firmware default. Entering it (or not entering it) in Cura will have no effect.

Most people find 833 to be a little high. You may want to do your own calibration. If you do, I recommend just setting the new value using the M92 command rather than entering it via Cura.

A link to Lulzbot calibration instructions is below. While written for a Taz, everything is the same on the mini – except you don’t have an LCD control, so ignore step 6 and use step 7 instead.
https://ohai.lulzbot.com/project/extruder_calibration/calibration/

Thank you, that is where I am a bit confused, on issuing the M92 command. Documentation says to hit “print” and issue it with a M500, just not clear on how one does that.

You must load a model in Cura and hit the “Control” button to get the Printer interface – because that’s where you can enter commands at the bottom-right, below the terminal window. Start by entering M501, which will show you the current settings – review to find the M92 line, and it should currently include E833.00 (the default value).

If your calibration gives you another number, lets say 815 for example, then enter “M92 E815” and hit enter. You can send M501 again to make sure it was accepted, then M500 to store the value. (If you don’t do the M500, it will revert to default the next time the printer resets.)

Understood, thank you for the assistance.