Mini not communicating

hi i recently received mini1 form a friend who asked me to look at it. printer powers on. i tried connecting with the lulzbot cura an was unable to do so but if i try the update firmware feature that works. firmware is flashed. i tried using regular cura and i am able to connect to the printer and everything seems to work. all the motors move the bed and extruder heat up. the problem i am have is that the software randomly looses communication. hitting the reset button on the board reestablishes it. i have tried three different usb cables. usb ports are set not to sleep. computer shows the board as Rambo board on com3. i tried connecting a raspberry pi 3 running octoprint and that was unsuccessful as well. not sure if its worth finding a new board.

I’d check for loose wires or flaky connectors. If you can establish a connection, try wiggling the wiring and see if that correlates with the disconnect. Sometimes a pin on the controller will have a cold solder joint which can easily be fixed with the light touch of a soldering iron.