New FlexyDually v2 not homing correctly

I am waiting for support to call me back on this as they are trying to replicate, but I am trying to install my new Flexydually v2. Following the OHAI guide, I am on step 32, which is actually printing out the test squares.

The problem is the Y-Home is messed up. It’s like I haven’t even installed the Dually. Toolhead 0 (furthest back), which is about where the original tool heads position would be, is where Y ends up when homed, which leaves toolhead 1 hanging about 2 inches past the plate. It’s actually about 50mm exactly off. So when you start to print, toolhead 1 (closest to front) just dumps straight down and doesn’t touch the plate.

I’ve tried reflashing the firmware as per techs suggestion (it uses 1.0.0.1 or something like that). Machine correctly states Taz 5 (Flexydually V2). In machine settings, Extruder 2 has X offset of 0 and Y offset -50. I don’t think it’s respecting those values, which is off by about 50mm if I use Taz’s control panel to manually move Y back. If I change the -50 to any value and then go to Home via Cura, it homes exactly where it always does with no change. I’ve changed it to 0,0 and it has not effect. 100,100 and no effect. I’m not sure what’s going on here. I’m just writing in case anybody else has any ideas while I try to work this out with support as they didn’t seem familiar with this problem. I’ve turned Taz off and manually moved the bed to center, powered on and then tried homing. All go to the same spot. I’ve only had Taz for a month so I’m not very experienced. I’ve done a lot of printing but it’s all been ABS so far and perfect once I got everything dialed in so I have not really even played with the expert settings or had to do much of anything until now.


Head 0 is where Head 1 is supposed to be for “home”

Home is not changed to the head 1 position. It is always the head 0 position(back extruder). So the front extruder hangs off the front of the bed when the printer homes.

Ok, but why would the front extruder start extruding when it’s not over the plate? Not leaking…full on extruding as in the picture?

That looks correct (well… at least from my Dual Extruder experience). Tool 1 will always hang over the edge because Tool 0 will be at home position. XY move requests always apply to T0.

I don’t know why T1 is extruding while at home… The toolhead should should move to the middle of the bed and print the calibration squares.

Thanks all. Support did get back to me and confirm that it was in the correct position but didn’t know why it was extruding.

I retraced the last few steps as far as loading the stl files, setting head 1/2 and bed temps and starting to print the calibration cube. The outer black square completed fine. When it was working on the green inner square, Taz just completely shut off during the 2nd loop like I flipped the power switch. Completely dead. No sound or smoke or anything. Tested the 2 small internal fuses on rambo as per tech support - no continuity. Also tested the thermistors, which seemed fine. They were around 50k when he had me test them, but an hour later they were around 95K which is closer to where they should have been (~100k) according to support. Strange. I guess the Flexydually and several reels of Ninjaflex I was planning on playing with this weekend for this project will have to sit there mocking me while I get this sent back. It’s always something lol. :angry:

Tech support was great and thorough. Kudos Aleph (Galen). I wish it was something easily resolvable and he did what he could to try to get me up and running.

I do not have a flexydually but it looks to be a nozzle purge. To clear any filament that has been sitting in the nozzle during the warm up cycle? There by giving you fresh material to use. Plus helping to prime the melt chamber.

I believe that’s probably what was happening. I just kind of freaked out when it started doing it when it wasn’t over the plate to catch it as I hadn’t seen it before.