New Mac Mini (M1 Chip) Cura Not Seeing Printer

Upgraded my Mac Mini to M1 - Taz Pro Printer. Mac sees the printer on the USB bus, but Cura Version 3.6.20 does not see the printer. Any ideas appreciated.

I have the same problem here on my m1 MacBook Air. Works fine via any other computer. Maybe it’s big sur?

I have a Mac Mini M1 using Cura LE 3.6.20 that prints just fine using Octoprint/Octopi on a Raspberry Pi 3B. I use it both on a TAZ 6 and Mini 2. I have not tried USB on either.

Yeah no issues with octoprint, it’s not the same as connect directly.

Hey, you can use parallels, sign up for the windows dev account and run the windows version of cura on you m1 through vm ware. It works fine for me.

Has anyone found a solution to this? I am having the same issue, Cura LE does not see my printer when I am directly connected. This really limits my ability to flash hardware and change heads. Octoprint has no issue, as I’m using terminal commands thru there to work with the printer. I’m having to run third party firmware that I can flash directly thru the chrome

Go ahead and download Cura LE 3.6.37. This version has had some upgrades to its pyserial dependencies and should have resolved the issue with the M1 Macs not connecting.

That fixed it, thank you very much