Printing from SD card on TAZ 4 just stopped (fire hazard)

This is my third print since I got the TAZ 4 last week. It happened to me on my first print when I was using a USB cable connected to my computer and pronterface. So I tried the SD card, and it worked fine.

But now this SD card print of a different model has stopped after two hours and 16 minutes. When I go to the menu on the LCD it shows the “Print from SD card” rather than stop or pause print, so it seems to have just reset itself, but the extruder did not move to the “done” position where the bed comes out to greet you when a project is done.

Because I used the SD card, I don’t see what line finished and which didn’t, so I can’t attempt to split up the Gcode file and have it resume (though I’ve never tried doing that, I heard it was possible).

My software on my SD card has one directory called “2014Q3” and I’m not sure if that’s the latest firmware or not, or even how to install newer firmware.

Any idea why this printer is pausing and ruining prints? Thanks for any help.

Pictures are of it stopped.

iPadMount1.gcode (168 KB)
Here is the Gcode file from the SD card:

I tried it a second time, exact same result. I’m guessing it’s a software issue, slic3r or something. Dunno.

I did skip exporting my Sketchup model in NetFabb this time, because when I loaded it, NetFabb didn’t find any errors miraculously. I wonder if skipping that step has led to this.

So I’m now trying to print it a third time, this time having used NetFabb to “auto repair” and export the STL, then slicing it to g-code. Fingers crossed.

The third print (exported from NetFabb despite nothing to repair) did get further along on the print. But still failed, stopping the extruder head in its tracks, keeping the temperatures at 230 and 85, burning a hole in the plastic and no doubt creating a serious fire hazard.

I could really use some help here.

Here is the video of it failing the third time:

Here is what I’m attempting to print, as shown in NetFabb:

Your gcode file is only 3 layers high so it looks like a software problem and not a printer issue. The printer is doing what it was told by the gcode file to do.

That makes sense. I suppose I could look at the gcode before I export it, and ensure the code is there that finishes the project before starting such a print job. I created the model in Sketchup, the Solid Inspector said there were no errors, I made it one group and saved the STL. Then I uploaded the STL into NetFabb and it found no errors, so I uploaded it into Slic3r and exported G-code.

I suspect the issue must be with Slic3r then. I’ll take a look there. Thanks for the help.

kmanley, how did you determine the G-code only has three layers?

kmanley, you nailed it. Turns out when I went to export from Slic3r, I hit the button and then I thought it was done when the document popped up on my desktop. I failed to see the progress bar at the bottom that was still going, and so I was grabbing the file before it was done exporting.

I have found the same problem sometimes.
Obviously the GCODE file would need some sort of ‘END of DOCUMENT’ sentence. Something that can be checked for file consistency.

Glad you found the problem!

I looked at it in the gcode viewer and saw it only did three layers before it got to the end of the file. Plus there are a BUNCH of lines that should have been at the end of the file, like turning off the bed heater and extruder. So that kind of told me your file was bad. 8^)

how did you determine the G-code only has three layers?

Load the G-code into this:


I’ve noticed that slic3r can take forever to save large gcode files. Try a different slicer to see if the file is exported faster–that’s pretty much why I use Cura.

It does… it will say something along the lines of

G1 X91.205 Y87.208 E1.10074 F600.000
G1 F1500.000 E0.00074
G92 E0
M104 S0 ; turn off nozzle temperature
M140 S0 ; turn off bed temperature
G28 X0  ; home X axis
M84     ; disable motors
; filament used = 9460.3mm (58.3cm3)

the “; filament used = 9460.3mm (58.3cm3)” is what you should look for. You also see shut down protocol.