Problem after z homing before wipe or level sequence

Problem persists even with a gcode that printed properly earlier in the day.

Tried refreshing the firmware, changed to standard head then back to dual. Problem persists.

I select print from SD, select my gcode file and everything starts like normal. It starts heating, homes x and y, then z, all apparently properly. But instead of moving to above the wiper it stays above the z target, pauses some, then proceeds to move -z contacting the z home button and deflecting it downward, then it proceeds to start the wiping motion at the z home button, and I shut it off before it destroys itself.

First thought was corrupt firmware, refreshing it didn’t change anything.

I tried a few different times reslicing it, same problem persists.

Any ideas?

Without seeing the gcode file we can’t determine if its garbage in or garbage out.

Thank you for the reply.

As I mentioned, it first happened on a gcode file that I had just successfully printed, so even though I wasted my time looking into the gcode, it is evidently not the gcode.

Here is the start of the gcode though. It’s so strange, it does fine up through home z, but it fails to move over to the wiper, just pushes back down on the home button and starts wiping there, ouch!

M106 S0
G26 ; clear probe fail condition
M140 S60 ; start heating bed
M104 S170 T0 ; start heating back extruder
M104 S170 T1 ; start heating front extruder
G28 XY ; home X and Y
T0 ; select this extruder first
G1 X-19 Y258 F1000 ; move to safe homing position
M109 S170 T0 ; soften filament for Z homing
M109 S170 T1 ; soften filament for Z homing
G28 Z ; home Z
G92 E0 ; zero extruder
G1 E-12 F100 ; retract 12mm filament
T1 ; switch extruders
G92 E0 ; zero extruder
G1 E-12 F100 ; retract 12mm filament
T0 ; switch extruders
G1 X-17 Y100 F3000 ; move above wiper pad
G1 Z1 ; push nozzle into wiper
G1 X-19 Y95 F1000 ; slow wipe

Do I understand you correctly, you print a gcode file from the SD card and it works, you print the same gcode file from the SD card and it fails?

What do you do to get it working again?

What printer? What firmware version?

Correct, same gcode files same SD cards worked and now don’t. I haven’t had it work again. I’ve tried a bunch of different old and new files and it usually fails the same way, though sometimes a bit different. Once it started correctly, probed pad one successfully, then started to pad two but only made it about a third of the way over then started to probe down at the glass yikes! Lucky I was there to shut it down.

It’s very strange, it’s like the firmware is getting confused as to where it should be going, which hints to me it’s an electronics hardware issue, but not sure.

I’m still experimenting, tried cura instead still failed. For the hell of it I just installed the latest cura will try it again. I’ll check firmware when I’m at the printer again. I guess when I change the firmware for changing toolheads it’s only replacing the firmware with my old firmware, I’ll look into getting the latest firmware.

To eliminate other errors, I have installed the latest cura, sliced the default (rocktopus) model with the default settings.

I recorded and linked for you two videos attempted printing twice in a row and it failed two different moments prior to probing the corners, though it seems to think it is at a corner because it it probing, but definitely probing in the wrong location.

I did also notice that the LCD and control knob seem very sluggish, and even a couple of times when I selected print from SD card that it rebooted the system, showed firmare version etc. then main screen, instead of going to the file list to select from. So I’m thinking it may be an electronics hardware problem corrupting the bed leveling routine, which I believe is not controlled but only triggered by the gcode, correct?

Link to download the 2 vids from wetransfer

What printer? What firmware version? Do you have a USB cable you could plug into the machine you are running Cura on (and is it Ultimaker Cura or CuraLE)?

Taz 6 with dual v3 head

Cura lulzbot ed. Though initial problem arose with simplify 3d my usual slicer, both give similar results.

I do have a cable to run from laptop I’ll try that too.

CuraLE 3.6.22 has Marlin (and for the TAZ 6 Dual Extruder V3.

Using a USB cable and driving the printer directly from the laptop will eliminate some part of the printer. You can also examine the printer’s response to each command as it is sent.

I’ll definitely try the cable and updating Marlin.

But, it did work for a couple of years with those versions of slicers and marlin. I would think if one of them went corrupt then the failure would be more consistent.

After it started happening I later tried changing the firmware to another tool head then back to the dual in the cura settings, and that didn’t fix it, so seems that the firmware didn’t somehow go corrupt. It’s all pointing me to electronics hardware, does that make sense to you? I’ll definitely try the cable next.

I think your assumption is probably correct and something in the hardware has gone haywire.

The SD card and the LCD display are separate from the actual controller board so if we can somehow isolate the problem, we don’t have to take a shotgun approach.

You say: “… it does fine up through home z, but it fails to move over the wiper …”. Maybe try that as a fault finding position. So what I mean is, try an auto bed leveling sequence which also includes a home z command. The reason being, after home z it will use the known dimensions of your TAZ 6 build plate and try and work its way around the plate doing the bed leveling.
So I would do:
M420 S0
G28 X Y
G28 Z
G29 V4