Software Hardware compatibility

I am having trouble getting Cura 17 to run on two of my systems. These are CAD Workstations
At work I am running Windows 7 Pro on a AMD Phenom II X4 Processor with 16G
At home I am running Windows 7 Pro on Z Xeon Haswell Processor with 16G
Cura will not start on either of these systems, no errors, nothing in the seems to start in the task manager.
It work fine on my laptop. Windows Vista Home and a Intel CoreDuo with 4G.

Any suggestions???

Installation completed successfully on these two Win 7 Pro machines?

When you try to launch Cura do you even see a splash screen?

No, the splash screen never appears.
The task manager processes never shows anything starting.

I have been investigating and it may be related to python, but not sure if that is the problem though.

I have tried Matter Control and Slic3r and they seem to be running fine.

Another person at my work has a Windows 7 system running it, but he has an Athlon Processor, that is reason I bring up the hardware compatibility. Somewhere I read the compatibility to hardware is Intel Core 2 and Athlon processor.

And yes completely loaded and initialized,best I can tell.


Can you try to open a command prompt (Start menu, then type ‘cmd’ and run it), then go to the Cura installation directory and run the cura.bat file :

 cd "c:\Program files (x86)\Cura_17.10"

Hopefully, this shows us what kind of error is causing it not to work.

Oh, and something else. There was a similar error that was reported a while ago that was caused by a conflict when someone installs the Haskell development on their system (maybe some other software is causing the same compatibility) and it caused the wrong openGL dll file (from Haskell instead of Cura) to be loaded, which prevented it from running in the same way you’re describing. I just checked and the fix for that wasn’t actually included in the 17.10 release (it came right after), so I’d suggest you try the 18.01 beta to see if the issue is resolved for you with that.
Beta available here:


This is the return at the command prompt

C:\Program Files (x86)\Cura_17.10>Cura.bat
Traceback (most recent call last):
File “C:\csvn\Python25\lib\”, line 162, in _run_module_as_main
main”, fname, loader, pkg_name)
File “C:\csvn\Python25\lib\”, line 72, in _run_code
exec code in run_globals
File “C:\Program Files (x86)\Cura_17.10\Cura\”, line 13, in
from Cura.util import profile
File “Cura\util\”, line 22, in
import numpy
ImportError: No module named numpy

I installed Cura_18.01 Beta
It seems to load fine and at the end asks to run. Like CUra 17
I tried running form the icon also.
No dice

I ran the bat file from the command line for it and received the same errors

Thanks for that, it looks like it’s an incompatibility with a different program you have installed which uses python :

File "C:\csvn\Python25\lib\", line 72, in _run_code

For some reason, that seems to take precedence and runs instead of the python installed with Cura, which is why it can’t find the proper python modules and fails. I don’t understand why that happens though since the Cura link specifically runs the python included with Cura.

In any case, do you know what the application in C:\csvn is ? Let me know so I can install it too, and test and eventually find a way to prevent the conflict.
Thank you.

This is fixed in Cura 18.03 (which is in beta right now) give it a try.

Thanks for reporting it!

I am not sure what “csvn” is, but I do run Tortoise SVN. We utilize an SVN server & repository for software development as well as hardware. I would assume it has something to do with that.

I tried Version 18 earlier and it did the same thing. I will download again and try it again.

OK, I had our Software Engineer look this over and this is the issue.

“csvn.exe” is in the system path and I need it to be there. It was put there by Collabnet SVN which I need to run on my system for my CAD software, Altium Designer and for Tortoise SVN. Altium Desinger has built in SVN support for project management. As I mentioned, I/we use SVN extensively for revision control on our parts and projects.

According to the Software Engineer, you need to do something with the Cura program to direct it to look for it’s local Python.

Cura 18.03 works great.
Thanks again