TAZ 4 + Cura LE 3.6

I’d like to use some of the new features in Cura LE, but my printer is an old TAZ 4. Is there any way to make it work?

So far I’ve tried using the TAZ 5 printer profile, but Cura fails to connect over USB. I’ve seen a couple of posts here on the forum where people suggest that they’re using the newer Cura LE with their TAZ 4’s, and as I understand it the 4 can be upgraded to a 5, which has a built in profile, so it seems possible.

I’m currently on firmware “2014Q3”. Thinking this might be related, I tried to upgrade to the “Marlin_taz_4.1_revb.cpp.hex” firmware (the latest version for TAZ 4 linked in the upgrade guide) using Legacy Cura. The upgrade progress bar gets about halfway and fails with “Verify error at: 0x0”.

So, is it possible to use the latest Cura with TAZ 4? :thinking:

After some tinkering I’ve found a workable solution. Instead of relying on Cura to both slice and drive the printer, I first slice in Cura LE 3.6 with the TAZ 5 profile, and then simply export a .gcode file. I’ve been using Pronterface on another dedicated computer to actually drive the printer. This workflow is actually better, since I can do my modeling and slicing all in one place.

Still unsure why the firmware won’t update, but I suppose that’s not really necessary now as Pronterface drives the TAZ like a champ.

Short answer, no. I also have a taz 4 using Cura le 3.6.20, and it works quite well. I primarily use usb, unless there is a complicated print that drip-feeding may not be ideal for. Also, I’m using ver for taz5, which is the latest stable release by lulzbot