Taz 6 Button Wheel Unresponsive and Clicking Itself

I’m having a couple likely related problems with my Taz 6. The first is that the button wheel on the Taz 6 stops responding after the printer has been going for a while. Usually it works after a hard reset, then after I print something it stops working, or is very unresponsive.

The other issue is that now occasionally when it prints it will act as if it’s pressing the button repeatedly. The LCD screen switches and the printer beeps as if the button is being repeatedly pressed. Pressing the button temporarily stops this behavior but it comes back right away. Here’s a video of what I mean:

I’ve tried upgrading firmware and am about to switch back to the normal extruder (I normally use the dual extruder v3).


It sounds like the button on the rotary encoder is stuck/intermittent. Have you tried reaching out to support? I believe it’s this part according to the BOM: EC11E15244B2


I haven’t yet, but I’ll reach out to support-- thanks for finding the part!