Taz 6 Problem with leveling, cleaning, and printing

Need help trouble shooting a problem. My Taz 6 printer I have had for almost 3 years now. I have been using the printer regularly without any issues daily. Yesterday, it was doing all the pre checks before printing i.e. auto leveling, wiping nozzle, etc. when I noticed it would wipe past the clean foam. It seems to think the bed is longer or the printer doesn’t not recognize the parameter length and width of the bed.

My question is: What should be should I do to alleviate this problem?

I have:
-Flashed the firmware and auto home the extruder
-I have re-leveled the X-axis and the Z-axis mentioned in the forums
-I have turned off the printer, let it sit for 15 minutes, then replugged it in.
-Plugged it into a computer via USB and tried printing that way

It seems none of these remedies are working. I currently own 4 of these printers and I just had to replace the logic board for one of them. I am hoping I do not need to perform another logic board replacement on this one. Any insight would be appreciated

Have you verified that each axis is correctly ‘homing’?

You can tell it to Auto Home and watch each axis…or you can use the Console in Cura (I use the Terminal in OctoPrint). G28 is the ‘home’ command but you can independently home each axis by giving it the letter.

For example

G28 X

This would home only the X axis (you can also use X, Y, or Z separated by spaces). If you don’t give it any parameters then it homes all 3 axes.

Anyway… I’m wondering if one of your axes failed to correctly ‘home’ (such as the Y axis) and that might explain why it’s going off the end of the wiper pad.

Mine did this a while back. I took a can of air and blew around the sensors and motors. Put a few drops of fine oil on the belt idle rollers and motors. Seems of have taken care of my issue for now.

Thank you all!

Both solutions worked!