x axis grining and not moving

Hello,

I am having trouble with my x axis. It is making a grinding noise when I “home” it and doesn’t move as freely as usual.

Here is a video: https://www.youtube.com/watch?v=Qy22e-L1MJc

I had e-mailed lulzbot support about this and they sent me a new motor. I changed the motor, however this has not solved the problem. In fact it now has a much smaller range of motion than in the video. Does anyone have any advice?

Thanks!

Your axis is homing weird. Usually when you hit home, the X axis will travel towards the X endstop, hit it, then the Y acis will go towards it’s endstop, then the Z axis will go down until triggered. Your X axis starts out heading the right direction, but then stops before it gets to the endstop and reverses direction. I’ve not seen one do that before that I can remember.

Here’s what I would do. pop the belt off of the motor and try that procedure again. with light finger pressure on the side of the motor pulley, see if the pulley is turning the correct direction when you hit home, see if it has constant motive force (no drop off of power or “soft” motion) make sure the pulley isn’t slipping, and make sure that it attempts to home in the correct direction, and manually stops when you trigger the endstop.

If the motor seems to work fine without the carriage and belt, check the idler side for bearing issues or an overtightened idler shaft. the bearings should freely rotate.

If the motor doesn’t work fine, then something else odd is going on. You need to check the X motor wiring harness fully from motor to board. check the X endstop wire as well. Look for any pins that aren’t seated in sockets, any areas of cable showing strain, etc.

If all that doesn’t resolve the issue, call support again.

I just fixed a printer last Friday that kind of sounded like that! That one had a blown RAMBo in it. The way the X axis is moving on that printer makes me think it has a bad control board also.

Thanks for your suggestions! I have taken the belt off and the motor shaft is not turning at all (it vibrated but won’t turn). I tried it with two separate motors and its the same with both.

I was thinking that either a) both motors are defective or b) there is a problem with the power supply to the motor. I couldn’t see any obvious issues with the wiring.

I’m not sure what to do to test to see if there is an issue with the program.

Or how to tell if there is a problem with the Rambo etc.

If you pull the belt off the Y motor and then swap the motor X and Y axis at the Rambo board, and the problem transfers to the Y motor, you have a bad Rambo board. If the issue remains with the X axis, you have a short in the cable path, or a swapped pin.

The way a stepper motor works, is there are two coil loops that work together to turn the motor shaft, add force, and make the motor work properly. The first coil is pin 1 and 2, the second is pin 3 and 4 of the 4 pin motor connector block. If one of those two coil loops are cut anywhere between the Rambo than you will get a motor that doesn’t turn strongly. It will move some, but just weakly, and can fail to move sometimes and or grind. It will be easier to turn in the correct direction, and offer resistance if you try to turn it against the direction it wants to go, but not nearly as strong as it would normally turn.

If you instead have one of the two pins swapped, you end up with a magnet coil in opposition to the other one, which ends up basically making two magnets fight for control of the motor shaft. In that scenario you will hear a loud buzzing and the shaft will vibrate but not move much at all, and will be hard to turn either way.

Based on the symptoms you are seeing so far, and the fact that you have replaced the motor already, the issue is one of the following (in order of likelihood):

  1. You have one or more pins loose at a wire harness connection point. (where the motor attaches to the wire harness, where the harness attaches to the Rambo, etc.)
  2. You have one or more pins swapped in the wire harness (pin came out, got put back in the wrong spot)
  3. You have a physical wire issue on the wire harness (warranty service issue)
  4. You have a bad motor controller or pin block on the Rambo board itself.
  5. your printer is actually haunted.
  6. Your printer is actually haunted, but that’s not the problem and it’s really also just broken.

Edit, if it were the power supply you would be experiencing other issues. It’s also very unlikely that both motors are broken. You can test them by swapping them in on the Y axis.

Thank you for the time you have spent writing out this thoughtful response. I will try out the things you have suggested and let you know how it goes.

Thanks!