Taz 6 Ringing/Resonance/Ghosting along the Z-axis


Writing to this forum in hope of possible solution.

I purchased my initial TAZ 6 unit on 14th of December from Microcenter. After installing the printer, I produced a roctopus print with NGen Standard Cura Profile which had slight ringing on the surface.
Right after that I started to get familiar with ABS and produced a 3d Benchy printed with standard ABS profile with local ABS fillament supplier. Once first ABS print was done, I noticed more pronounced ringing same as NGen’s roctpous print.
The reason that it wasn’t as obvious as ABS is because NGen is considerably easier to print due to ability of using cooling. My project requires strictly abs print workflow, because final model will be smoothened in ultrasonic acetone chamber, see the link for details (https://www.youtube.com/watch?v=PivH4Dm3ysw)
At that point I started to troubleshoot the issue.
First I went through numerous forum posts and tried to find a solution that would eliminate/decrease this artifact. This allowed me to get more familiar with structural components of the printer and get a good general knowledge on it.
Next thing was to reach out to Lulzbot tech support team. They kindly gifted their time and started to troubleshoot the issue together with me. We went through calibration procedures indicated on the OHAI support portal, purchased Village plastic ABS to ensure that imperfections are not due to the locally purchased ABS (which in all honesty is a great product). Purchased Printed Solid enclosure case to make sure that ambient temp during printing remains stable.
None of the approaches delivered improvements to this issue. After many tweaks and fixes, support team advised that we tried all the options and the unit has to be replaced.
After printer has arrived to facility and diagnosed, it was determined that toolhead was faulty.
Once I received the second unit, I noticed numerous upgrade on the structural components which gave me a confidence that this unit will produce considerably improved print quality.
Started to print with good high quality ABS fillaments together with village plastic and observed similar ringing across the print surfaces as per initial unit.
Then I made sure everything is lined up and belts are properly tensioned (great belt tension out of the box). Upgraded printing surface to Buildtak(so far the only good experience in terms of upgrades) which allowed me to print ABS with 75 degrees on build plate and still provide great adhesion. Also made first layers to look great.
Still there is ringing/ghosting on the prints…
Lastly we tried yesterday to adjust e-steps, fully turn off the heated and print Z resonance tower.
The issue is still present and I’m in a very though situation as my initial plan was to provided 3d printed parts to customers and make profit.
Currently and this is 100% my reality. Running low on the budget have no working solution to start earning income from this project.

Attached images are the latest printed 3d scanned artifact consists from 3 sections (later been glued together). The headdress and bottom section has a layer height of 0.1mm which is considerably high, face section is 0.2mm medium quality. All sections been printed on standard unchanged settings.
What I get in these prints, is observed as a resonance pattern coming from some loosen/misaligned or damaged component. Changing basic print setting, simply expands or shrinks the effect.

Another note regarding acetone smoothing, it’s a post process solution which after such printed ringing effect recreates wavy smooth surface, see attached.

Lastly, all the structural components been check for any lose play in them, belts are tight out of the box in good condition still.

Please address this matter and help to find peace in this situation.

Thank you,


Did you already do the firmware update to resolve the interlayer temperature pid autotune vs bang / bang temperature regulation issue that was present in the stock taz 6 release? That looks like what you are dealing with.

Details here

Yes, attached screencap is the details on the latest firmware. As per suggested post; it begins promising, closer to the mid results are the same and it ends with a sad note… Currently performing following calibration: https://ohai.lulzbot.com/project/squaring-taz-6-frame/

Followed the guide, everything was initially right on. Can someone post a sample of 3dBenchy printed with abs on a high profile?

After few adjustments (will go over in detail on the next post), printed 3dBenchy straight from SD card. With default settings using NGen filament. Can see the ringing across the hull, but it’s less pronounced. Will be producing an ABS version tomorrow and follow up with the progress.

Adjusted X Carriage even more accurately by using digital caliper. Printed with Default IC3D ABS profile on standard quickpint profile. After 2-3 layers shutoff the heated bed to see if it improves the ringing. Attached are the results, still visible resonance across the hull. Producing second ABS print with revised e-steps in order to compensate over extrusion. Also re-adjusting X carriage as per this guide: http://richrap.blogspot.ca/2017/04/lulzbot-taz-6-testing-part-2-problems.html.

One thing you will want to change, you are starting new layers on the outside perimeter. All of those “zits” on the print are new layer start points. You want to adjust your slicing program to “start new layers on inner perimeters only” . I see no evidence of ringing on that print. I do see layer inconsistencies though. Tighten your idler tension bolts another 1-2mm and see if that helps. You are overextruding slightly on the first layer, but thats normal for a new printer setup (promotes better adhesion) if you are satisfied with how well the parts are sticking, you can back the first layer overextrusion setting off a little bit, that will eliminate that issue.

Is the fillament cooling fan (not the always on barrel cooling fan) running while you are printing that? it shouldn’t be other than for the stack. and maybe the tower pillars. To see if overheating or overcooling is a factor, try printing two of them at the same time with no fan on and see if quality improves or gets worse.

Appreciate your feedback. All the minor artifacts such as “zits” could be fixed with suggestions as you described. Main and unresolved issue is the resonance that you can clearly see on the first 3 pictures of the latest printed benchy. The same effect happens across all the prints and ruins the overall print surface… Currently setting up Simplify 3D with standard Cura settings and additional suggested tweaks.

Ringing would typically show up as artifacts around things like the hawse hole in the front of the hull there, and would show up as repeating less prominent variants of a pattern involving sharp corners. it looks like this https://www.simplify3d.com/wp-content/uploads/2015/09/Vibrations-And-Ringing.jpg . It is only found in the X and Y axis for the most part. In the Z axis, it can be “Banding” or “Z wobble” or “inconsistent interlayer extrusion”. The latter is probably what you are dealing with. Banding and Z wobble are usually very much tied to the shape of the leadscrew threads, and almost always shows up as an offset that matches the leadscrew thread when the part is held up against it… Inconsistant extrusion, such as you are displaying on that benchy is tied to the Extrusion and can have several causes, from crap fillament, to improper idler tension via loose idler bolts, or gummed up hobbed bolts. Sometimes also loose small gear setscrews or electrical issues witih the heater core or thermistor. it can also be caused by either too little barrel cooling fan, or too much fillament cooling fan with ABS. Retraction settings can also come into play a tiny amount, and yours are off a bit based off the amount of layer start plastic blob present, but not to the point where its affecting the rest of the layer.

Yes, thank you for describing. Attaching latest prints made with VP Abs, adjusted e-step, printed in Simplify 3d on default Cura settings with some change, fans off, bed turned off after layer 3. Similar effect was on the different Ultimaker Abs filament. Have checked all the tension and calibration. It happens with NGen filament as well with fans on with default settings.

What is the best/correct way to fix this?

The problem with troubleshooting inconsistent extrusion is there are soooo many variables. What it boils down to is filament feed out the nozzle. Something, somewhere in the filament path you are using you are getting either drag, binding, or heat issues. You want to start with the spool end and work your way towards the nozzle, eliminating things as you go. Here is a good overall troubleshooting guide


If it were my printer, I would start with the spool. Does it only take a minimal amount of force to pull new filament off of it? Is the roll 6lb or less? (Larger rolls can require assistance to feed right) . Then check the feed path. Are you using the guide tube, is filament binding in it? Is it secured to the anchor too tightly with the tube anchor zip ties that are creating drag on the filament? If you cut a piece of filament off the roll and pull it through the guide tube it should take almost no more effort than pulling it across a table.

If the feed path is fine, it’s time to check the extruder. Is the idler cracked or otherwise deformed. Can filament move through the idler feed notch properly? Is the idler bearing able to freely move? Are both idler arm bolts the same length adjustment? Is the bird nose plastic thingy intact and not cracked. Is the main gear true, flat and not missing teeth? Does the deepest part of the Hobbed bolt line up with the hole in the extruder body (if not adjust with washers). With the motor off the extruder, does filament feed into that hole easily with no play on the main gear and no binding? If the gear moves front to back, tighten the nut. Check the small gear for wear and broken teeth. Put the motor back on, extruder 40mm worth of filament into the hotend and then pull it back out and check the teeth pattern on the cold plastic. Is it constant, no shallow spots or gouges?

If all that checks out, it might be the thermistor or the barrel cooling fan. Your prints otherwise look fine so I don’t suspect that, though that firmware issue earlier would produce the exact pattern you are seeing too.

This is a print sample from the first printer which had this same issue. After diagnostic it was determined that toolhead was faulty. Regarding spool path, rest assured it’s as per original guide with clear path. Even tested from the top to make esier path, see attached. Later found original spool more convenient, since it’s been on continuous troubleshoot.

Post some pictures of the extruder if you don’t mind, with the idler closed and open, and one showing the gears. I might be able to see something

Appreciate your time and support!

The idler guide fingers look a little shorter than normal, but that shouldn’t interfere much at all. How is the fit on the front bearing of the hobbed bolt? Contact pattern on the fillament looks decent. Id consider tensioning the idler a bit more. Aside from that it looks correct.

Thank you Tim! I will get in touch with support and escalade the issue.

What speed are you printing? What layer height?

Latest prints were made with standard settings, .2 mm layer height, no fans, 3600mm/min. 3d scanned artifact (first attachemnt set) consists from 3 sections (later been glued together). The headdress and bottom section has a layer height of 0.1mm which is considerably high, face section is 0.2mm medium quality. All sections been printed on standard unchanged settings. I printed with lower 2800mm/min and the same issue is still present.

After speaking with support, been advised to make a Z tower resonance print to see if the lead screws are performing as expected. It was printed with default Cura Standard quickprofile, decreased bed temp to 0 degrees after 2nd-3rd layer. Attached are the latest prints together with Z tower print. There is a visible binding on Z tower test, yet it’s not as pronounced as on curved surface or other prints. Appreciate everyone’s time and assist on this case.

Oh, do you have that “solid layer ever X layer” setting turned on? You’re overextruding a little bit every 8 layers on the tower.
Also hold the printed tower up next to the leadscrew and see if the distortions match the threads exactly.