TAZ 6 Troubleshooting for Student Use

Hi there everyone. I hope you all are well and I would first like to say thanks to the community for letting me lurk for a bit before I decided to make an account for my issues. :grin:

Some context: I’m a student at a state university, and we have a 3D print lab that I work in as one of the technicians. We primarily work with Prusa printers, but we recently came into possession of a TAZ 6 printer and we are very excited to use it. I’ve been tasked with setting it up properly so that students can use the printer for projects.

Background for the printer: it came from a group of four TAZ 6s from the Engineering school, where they “rarely” used it, and most likely printed in ABS.

We only use PLA due to its relative safety within a ventilated area that gets populated with student projects often. I flashed the newest update of the firmware to the system and loaded up some 2.85mm PLA filament that my professor provided to me. He did tell me that the PLA he had in that size was a bit off-kilter (it had been sitting in a bin for a while) but I still gave it my best shot.

We began having issues right away. The first and foremost issue was, as predicted, the filament–it was definitely moisture-damaged, so I chalked up a lot of “blobbing”, dragging, and stringing to that. This was also from me using the default TAZ 6 profile on Cura (which I hadn’t used before).

My next idea was to try using our ample 1.75mm PLA filament, which we use with our Prusas, and I double checked to make sure that it would be okay in the TAZ (sounded like yes, so long as the gcode settings were correct). But even still, we run into issues–there seems to be a problem with the infill (gets streaky) and with layering (there are often gaps).

I’ve tested just about everything I can think of–I tried different presets in PrusaSlicer for the TAZ 6, I’ve tried cold/atomic pulls, I’ve tried calibrating the z-offset and e-steps about a dozen times, and yet we keep running into problems.

I don’t want to throw in the towel, but my knowledge only goes so far. I’d like to turn to the community for some help. Any suggestions are appreciated. Considering we essentially received it for free, we’re not terribly keen on replacing a bunch of parts, but if something like the nozzle or the abrasive pad can be swapped out, we’ll do that.

Thank you all for taking the time to read and help me out. We appreciate it!

First thing that catches my eye is you are using 1.75mm material in the stock Taz 6 tool head??

Yes, I figured it’d be an issue at some point. I’m going to pick up at least a small roll/bundle of 2.85mm PLA because I believe the stuff we currently have is damaged.

It’s “workable” but I don’t think it’s sustainable in the long run without purchasing an appropriate toolhead (which I don’t think we want to do).

It’s something I should have suggested right away.

Yeah I have a Taz 6 and the stock toolhead…well…I have a love and hate relationship with it. Sometimes it works great, others…it just doesn’t.

For my, I plan to purchase the M175 toolhead and adapter plate needed to use it. Then I gain some high end components - the Bondtech extruder, the Slice Mosquito hot end and I am using 1.75mm material since that’s most of my print lab at home.

Get some Polymaker 2.85mm material and then test again. Small steps.

Also, great resource here


1 Like

Thank you SO much for the link. While I’m no stranger to calibration, the TAZ 6 is like a big unruly stallion. It scares me a little.

Thanks for the Polymaker suggestion, I was considering a small spool from Gizmo Dorks, but I might also check my local hobby store to see if they have any in the 2.85mm size.

I figured out after some time in that the TAZ 6 can be a bit of a toss-up. For some, it works great–for others, maybe not so much! And since most students here are more involved on the “artistic” side of things (i.e. making the models) it’s usually up to me and the professor to troubleshoot the “tech” side. The TAZ 6 is quite industrial compared to the Prusas, which feel like a more “end-user friendly” machine.

Well here’s some more suggestions…here’s my YouTube Channel and my Taz 6 upgrades

The Taz 6 is an oldie but it certainly can still print. I wish there was a plug n play board upgrade to quiet the thing down :slight_smile:

Also, give Cura LE a go.

Having used my share of 2.85mm, I’d go polymaker over gizmo dorks. Matterhackers Pro PLA is also pretty good at this size, but the price is prohibitive. I use it for work since consistency of color was key over several years of production.

The stock taz 6 head’s only saving grace is that it’s easy to clear the frequent jams.

If you’re sticking with 2.85mm, buy a 2.85mm orbiter extruder ($60 on aliexpress) print a simple adapter plate,
Flexorbiter Adapter v1.stl (4.3 MB)
do the wiring change and GCODE changes to account for the motor.

I have pushed just about everything with this. 65A “hardness” rubber filament, PLA, polycarbonate. I did get the rubber wrapped around a gear once, but that was definitely operator error.

Archim2 with drunken octopus is the closest you’re going to get… but for that price, you can do SKR 1.4 w/Hermit Crab (which includes cables to account for the plug length), and roll your own firmware.

Lots of upgrade paths.

Hi everyone, thanks for all the suggestions and replies :smiley: I’ve come back to the lab today with a fresh roll of PolyTerra 2.85mm PLA filament.

I tried printing right off the bat, got some poor results. Then I decided to re-calibrate E-steps, and they were off, so I fixed that up as best as I could.

I’m also trying out some custom gcode to skip the wiping process (which has been a little problematic) and instead extrude out a purge line at the bottom of the print bed, since I noticed that prints would often fail to extrude the brim and would start printing somewhere in the middle of the initial layer. (A clog? Bad E-steps? Stripped extrusion screw?)

I’m only scared that if having fresh filament and re-calibrated E-steps doesn’t solve the problems, that the issues are internal, and I’ll have to disassemble the hotend assembly.

By the way, this is what the filament looks like after another cold/atomic pull. It looks very… “bitey” if that makes any sense? Like the gears really dug into it, more than usual. But maybe this is normal–correct me if not.

Thanks again for all the help everyone.

That bite looks about normal for the single extruder. Maybe a touch too much tension, but with one hobbed bolt and an idler, it needs to dig in.

The wiping process is there to clean the nozzle so that the washer-based leveling system can work. Going with BLTouch (or a clone) will let you go with a prime line or skirt to prime the nozzle.

The biggest source of problems with the Taz 6 center around bad measurements with the washers. A lot of people don’t believe that there’s plastic interfering with the measurement, and start playing with Z offset instead of properly cleaning the nozzle. PLA on the wipe pad has a tendency to stick to the nozzle. The only times I can say the washer-based leveling was very reliable for me was when using ABS filament, a hardened steel nozzle, and a scotch-brite scrub pad in place of the standard wipe pad.

PLA is just too sticky and oozes too readily, even at lower temps to come off the nozzle with perfect reliability. A good coated nozzle (micro swiss) helps, but there’s a reason that Lulzbot is about the only people who tried to use this leveling system. It has advantages for swappable toolhead configurations, but swapping toolheads is occasional, while bed leveling happens on every print… so a system that makes 100% of your prints easier is better than a system that makes an occasional change easier.

I’ve struggled with the washer based leveling, but found if I do one more G12 wipe at the probe temperature it will almost guaranteed never have issues probing.

heat to retract temp
heat to wipe temp
heat to probe temp
G12 again
then probe G29

The theory here is that whatever has oozed prior to wipe is sufficiently cool to flick off when it wipes again.

So, as a summary to what you said:

  • Washer-based leveling is kinda unreliable.
  • If we’re not using swappable toolhead configurations, it’s not the best solution for us.
  • A better solution would be using a BLTouch configuration.

I would agree with the washers being kind of unreliable–I’ve had times where it’d level off on the washers and really push them down, and other times where it would lightly tap. While I don’t know how comfortable I’d be with fiddling with the wiring of the extruder, it might be worth a shot.

I’ll give this a shot for now. If this still grants me poor results, I’ll look into the BLTouch. Thanks so much.

Most recent results after trying the custom wiping… Ouch!

I’ve had better and worse… It’s almost like it’s not extruding enough in its passes, or gaps are being created in the filament as it extrudes.

I think I’m really lost for ideas at this point. I’ve cut its speed in half, fiddled with flow, tried dialing in the temperature, even used custom gcode…! I’m going to try printing one last cube tonight, and then it’ll be left until Friday, when I’ll try to work on it again. (I’m feeling a bit more hopeful as the one being printed right now seems to have a smoother-looking outside, but it also looks like it’s getting a little squashed.)

Again, thank you all so much for the help and suggestions… I’m still learning about this machine and I consider it a great learning opportunity (if really frustrating at times!) to be working on this TAZ 6.

Interesting development… I don’t know how this happened, why it happened, or how to fix it.

I shut off the printer for the evening, and decided to poke around at the toolhead. I pulled out the filament and… it seems to have gotten stretched within the extruder so super-thin that it actually became hollow in the middle. I’m baffled. Really.

Is the hobbed bolt full of filament on one side, so you’re only extruding for like 66% of the time?

Back in the lab today, got to briefly meet with my professor and we talked about the results so far. He agreed that the quality seemed to get even worse, somehow, despite using brand new filament at the correct size.

I think I’m about half getting what you’re saying–are you saying that the hobbed bolt itself might be clogged, and thus it’s preventing flow? Maybe. We both noted that when the filament is loaded in, it’ll purge out a clean little lump of filament (nice and smooth, though it usually fails to get any filament through on one purge alone) but when it prints, it comes out, well… bad.

We also discussed that this seemed to be a common issue with other TAZ 6 machines. Some people could get it up and working just perfect right away, while others struggled through iterations of testing to get it to print in a reasonable quality.

I brought up how the problems may be internal, and I was nervous about how deep I’d have to dig into the toolhead to fix or diagnose anything, and his first suggestion was to try purchasing a new nozzle/heatend. So we’ll probably be trying that at some point as well, just in case this nozzle is just bunged out from using ABS for who knows how long. Otherwise I was recommended to check out the tensions of screws and such.

I think the main issue that we’re having is this: the filament just doesn’t want to extrude when it needs to. When the printer’s sitting idle after I cancel a print or after I load, it’ll “leak” a string of filament out. Significant strings, longer than 1 inch/3cm. But when it comes down to actually printing–it’ll fail to print the skirt, and now it’ll also often fail to print the first layer, too. What the hell is up with it? What makes this thing tick? What makes it work improperly in these situations?!

If I had received this from a friend who wanted me to fix it, I would have given up a long time ago. I would have told them to find somebody who actually knows how these machines work before I rip it open with pliers… but since this is for students, I want to see it through. I’ll be running more tests today and see what I can do.

I saw this thread about having print failures, and it’s given me a vague idea of where to try next.

I won’t lie, the gears on our extruder look nasty, kind of gunked up with dust and such. I wonder if giving them a clean and once-over might help. I might try to look into that, but I’d have to figure out how the hell to take the extruder off the assembly first.

Could be a gear failure. I had a set screw hole that got out of round that would allow the screw to angle enough to occasionally slip. Freshly printed gear and moving over the captive nut and screw over to it solved that problem.

A new toolhead is quite extreme. Generally these hexagon hot ends are very easy to deal with. Do some good cold pulls to ensure the nozzle is good and clean. Inspect the actual nozzle hole (maybe it got banged into a washer or worse?). If you can manually push filament through the nozzle at operating temperature, and it comes straight out (instead of pigtailing) the nozzle should be good, and the issue is with the extruder’s ability to push.

Trying to go to fast is bad, going too slow is also bad. The best thing to do is to use Cura LE and an unmodified print profile to get a baseline.

Keep in mind that the Taz 6 single extruder is not a great match for PLA. If you are going to continue to use PLA and get a new toolhead, do make it another Single Extruder. The SE 0.5 is ok-ish with PLA, or you can slap an orbiter extruder in place of the Wade Extruder and have a very strong toolhead.

Nozzle seems to be OK, filament pushes out just fine and smooth whenever it’s purging/being manually pushed. I feel like it may be a gear issue since everything else should be alright.

Something else I’ve been thinking of… What if it doesn’t have the stock toolhead? I’ve been assuming this whole time that it has the default .5mm Single Extruder nozzle, but what if it’s the SE Nickel-Plated Copper .5mm nozzle? Is there any reliable way to tell aside from visual inspection?

Well, I suppose trying the other Cura presets for .5mm nozzles couldn’t hurt. I’m going to try the Cura preset for TAZ 6 with an SE nickel-plated copper nozzle, see if that makes a difference, if not I’ll go back to the normal Single Extruder nozzle.

We’re not thinking of replacing the entire toolhead, just the hotend. But again, if I’m not entirely sure what hotend is on there, I’d better double check.

The SE is not the single extruder. It’s based on the Titan Aero toolhead, while the Single Extruder is a Wade extruder on top of a Hexagon hot end. Using those profiles in Cura could lead to some issues.

The original (Micro Swiss) nozzles are round with two flat sides. Most aftermarket nozzles are hexagonal in shape.